Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

分析

起先用set做的,最后一个点超时了。

#include<iostream>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
char name[40008][5];
vector<int> courses[2508];
bool cmp(int a,int b){
return strcmp(name[a],name[b])<0;
}
int main(){
int n,k,cnt,course;
cin>>n>>k;
for(int i=1;i<=n;i++){
scanf("%s %d",name[i],&cnt);
for(int j=1;j<=cnt;j++){
scanf("%d",&course);
courses[course].push_back(i);
}
}
for(int i=1;i<=k;i++){
printf("%d %d\n",i,courses[i].size());
sort(courses[i].begin(),courses[i].end(),cmp);
for(int j=0;j<courses[i].size();j++)
printf("%s\n",name[courses[i][j]]);
}
return 0;
}

最新文章

  1. Android Weekly Notes Issue #219
  2. mvc中测试网络
  3. ftp发送文件
  4. React模板
  5. Dubbo在Spring和Spring Boot中的使用
  6. 再次探究Android ListView缓存机制
  7. OpenSuse13.2硬盘安装
  8. jQuery插件开发入门
  9. iOS-延迟操作方法总结
  10. hdu_1728_逃离迷宫(bfs)
  11. python利用scrapy框架爬取起点
  12. React学习笔记--程序调试
  13. Django中使用geetest实现滑动验证
  14. python 类的属性__slots__ (了解一点点)
  15. 前端部分-CSS基础介绍
  16. SQL与MySQL基本
  17. Linux下的SVN服务器搭建(转)
  18. jsonp跨域简单应用(一)
  19. Petrozavodsk Summer Training Camp 2017
  20. mysql里面 limit的奇效

热门文章

  1. ios6--UILabel
  2. JZOJ 1003 [ 东莞市选 2007 ] 拦截导弹 —— 递推
  3. springmvc的jar包
  4. Hadoop - WordCount代码示例
  5. Android基础整理
  6. yii2表单,用惯yii1的可以看一下,有很大不同哦
  7. AcWing算法基础1.2
  8. ACM_Mystery
  9. Hadoop Hive概念学习系列之hive里的HiveQL——查询语言(十五)
  10. Java系列学习(零)-写在前面的话