转载请注明出处:http://blog.csdn.net/u012860063

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 

As an example, the maximal sub-rectangle of the array: 



0 -2 -7 0 

9 2 -6 2 

-4 1 -4 1 

-1 8 0 -2 

is in the lower left corner: 



9 2 

-4 1 

-1 8 

and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1 8 0 -2

Sample Output

15

Source

题意:给你一个N*N的矩阵,求当中和最大的子矩阵的值!

代码例如以下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
int i, j, k, t;
int a, sum, max, N, m[147][147];
while(~scanf("%d",&N))
{
memset(m,0,sizeof(m));
for(i = 1; i <= N; i++)
{
for(j = 1; j <= N; j++)
{
scanf("%d",&a);
m[i][j]+=m[i][j-1]+a;//表示第i行前j个数之和
}
}
max = -128;
for(i = 1; i <= N; i++)//起始列
{
for(j = i; j <= N; j++)//终止列
{
sum = 0;
for(k = 1; k <= N; k++)//对每一行进行搜索
{
if(sum < 0)
sum = 0;
sum+=m[k][j]-m[k][i-1];
//m[k][j]-m[k][i-1]表示第k行第i列之间的数
if(sum > max)
max = sum;
}
}
}
printf("%d\n",max);
}
return 0;
}

最新文章

  1. 学习ASP.NET Core, 怎能不了解请求处理管道[3]: 自定义一个服务器感受一下管道是如何监听、接收和响应请求的
  2. mysql报错: 1548-Cannot load from mysql.proc. The table is probably corrupted 解决办法
  3. (原) 2.3 Curator使用
  4. 【bzoj2104】 K-th Number
  5. Rotate Array
  6. Maven使用笔记(六)使用Maven进行多模块拆分
  7. 一个异常与Android Studio系列教程参考
  8. Ext 中xtype一览
  9. Altera quartus II遇到的问题
  10. 【从零开始自制CPU之学习篇00】开篇
  11. RabbitMQ防止消息丢失
  12. MVC和普通三层架构的区别
  13. 在 Linux/windows下 命令行中使用和执行 PHP 代码[交互式php]
  14. 全网最详细的U盘被损坏导致一般性的软件无法修复的解决办法(必须可以)(图文详解)
  15. Spark Shuffle原理解析
  16. Windows10更改网络类型-公用-专用
  17. Linux跑火车,提升趣味性
  18. etcd基本操作
  19. 折半搜索【p4799】[CEOI2015 Day2]世界冰球锦标赛
  20. RabbitMQ脑裂

热门文章

  1. CCF认证题 搜索题
  2. iOS-----5分钟学会枚举的正确使用姿势-Enumeration宏
  3. poj 1981 Circle and Points
  4. c#.net分类上升达人~~~呵呵。。。
  5. 应用defineProperty简单实现vue的双向数据绑定
  6. 现象: shell脚本中source aaa.sh时提示 source: not found
  7. LeetCode OJ——Climbing Stairs
  8. 在Eclipse中打开Hadoop工程
  9. HDU 5733 tetrahedron(计算几何)
  10. 死磕 java同步系列之AQS起篇