题目链接:http://poj.org/problem?

id=3368

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1
≤ i ≤ j ≤ n
). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000
≤ ai ≤ 100000
, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two
integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 

query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source

PS:

RMQ介绍+模板:http://blog.csdn.net/u012860063/article/details/40752197

代码例如以下:

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std; const int maxn = 100017;
int num[maxn], f[maxn], MAX[maxn][20];
int n;
int max(int a,int b)
{
return a>b ? a:b;
}
int rmq_max(int l,int r)
{
if(l > r)
return 0;
int k = log((double)(r-l+1))/log(2.0);
return max(MAX[l][k],MAX[r-(1<<k)+1][k]);
}
void init()
{
for(int i = 1; i <= n; i++)
{
MAX[i][0] = f[i];
}
int k = log((double)(n+1))/log(2.0);
for(int i = 1; i <= k; i++)
{
for(int j = 1; j+(1<<i)-1 <= n; j++)
{
MAX[j][i] = max(MAX[j][i-1],MAX[j+(1<<(i-1))][i-1]);
}
}
}
int main()
{
int a, b, q;
while(scanf("%d",&n) && n)
{
scanf("%d",&q);
for(int i = 1; i <= n; i++)
{
scanf("%d",&num[i]);
}
sort(num+1,num+n+1);
for(int i = 1; i <= n; i++)
{
if(i == 1)
{
f[i] = 1;
continue;
}
if(num[i] == num[i-1])
{
f[i] = f[i-1]+1;
}
else
{
f[i] = 1;
} } init(); for(int i = 1; i <= q; i++)
{
scanf("%d%d",&a,&b);
int t = a;
while(t<=b && num[t]==num[t-1])
{
t++;
}
int cnt = rmq_max(t,b);
int ans = max(t-a,cnt);
printf("%d\n",ans);
}
}
return 0;
}
/*
10 3
-1 -1 1 2 1 1 1 10 10 10
2 3
1 10
5 10
*/

最新文章

  1. FFT时域与频域的关系,以及采样速率与采样点的影响
  2. Openfire用户密码加密解密
  3. Robot Framework:RF中对时间操作的datetime库常用关键字
  4. Ruby-递归和尾递归
  5. Quartz-2D绘图之图形上下文详解
  6. 【Ecstore2.0】导出问题解决(未导出或导出文件为0字节)
  7. 在Ubuntu上下载、编译和安装Android最新源代码
  8. POJ22230 Watchcow (欧拉回路)
  9. 【滚动数组】 dp poj 1036
  10. Fragment已经被added了导致的异常。
  11. crontab -e 怎么保存后退出?
  12. poj 3304 Segments 线段与直线相交
  13. ElasicSearch(3) 安装elasticsearch-head
  14. Bootstrap手风琴效果
  15. android 网络图片双缓存
  16. javascript publish/subscribe or observer pattern
  17. Java静态内存与动态内存分配的解析
  18. Centos 7 配置单机Hadoop
  19. CLR_Via_C#学习笔记之CLR的执行模型
  20. C语言错误 指针的类型错误

热门文章

  1. CSS3特效——六面体
  2. SpringBoot2.0中使用订阅redis的多个频道的消息
  3. -bash: wget 未找到命令的解决办法
  4. 循环语句第3种 FOR ... in ... LOOP END LOOP;
  5. 新建Eclipse工作空间,复制原有的配置(转)
  6. HDU2188 悼念512汶川大地震遇难同胞——选拔志愿者
  7. NHibernate3剖析:Query篇之NHibernate.Linq增强查询
  8. java中的system.out.println()和JSP中out.println()差别
  9. Android上方便地开发的C程序
  10. caffe环境配置