Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 919    Accepted Submission(s):
501

Problem Description
dxy has a collection of a series of books called "The
Stories of SDOI",There are n(n≤19)

books in this series.Every book has a number from 1

to n

.

dxy puts these books in a book stack with the order of their numbers
increasing from top to bottom. dxy takes great care of these books and no one is
allowed to touch them.

One day Evensgn visited dxy's home, because dxy
was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn
was curious about this series of books.So he took a look at them. He found out
there was a story about "Little E&Little Q". While losing himself in the
story,he disrupted the order of the books.

Knowing that dxy would be back
soon,Evensgn needed to get the books ordered again.But because the books were
too heavy.The only thing Evensgn could do was to take out a book from the book
stack and and put it at the stack top.

Give you the order of the
disordered books.Could you calculate the minimum steps Evensgn would use to
reorder the books? If you could solve the problem for him,he will give you a
signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

 
Input
There are several testcases.

There is an
positive integer T(T≤30)

in the first line standing for the number of testcases.

For each
testcase, there is an positive integer n

in the first line standing for the number of books in this
series.

Followed n

positive integers separated by space standing for the order of the disordered
books,the ith

integer stands for the ith

book's number(from top to bottom).

Hint:
For the first
testcase:Moving in the order of book3,book2,book1

,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4)

,and this is the best way to reorder the books.
For the second testcase:It's
already ordered so there is no operation needed.

 
Output
For each testcase,output one line for an integer
standing for the minimum steps Evensgn would use to reorder the books.
 
Sample Input
2
4
4 1 2 3
5
1 2 3 4 5
 
Sample Output
3
0
 
题意:一摞书顺序乱了,让你按照序号从小到大的顺序将其排列整齐,一次只能拿一本书,且必须放在最上边,问最少多少步可以实现
题解:先算出已经按顺序排好的书本的个数sum(注意这个序列并不一定连续,而且必须是从某个数到n的序列),用n减去sum即可
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 100100
using namespace std;
int a[MAX];
int main()
{
int n,m,t,i,j;
scanf("%d",&t);
int maxx,ans;
while(t--)
{
scanf("%d",&n);
maxx=0;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
if(maxx<a[i])
{
maxx=a[i];
ans=i;
}
}
int ant=ans,sum=0;
for(j=ans;j>=1;j--)
{
if(a[j]==a[ant]-1)
{
sum++;
ant=j;
}
}
printf("%d\n",n-sum-1);
}
return 0;
}

  

最新文章

  1. imx6移植ffmpeg2.3
  2. Android开发:在EditText中关闭软键盘 转来的
  3. display~
  4. raiserror的用法
  5. Robotium学习笔记一
  6. sqlserver 2008 sa登陆的一些问题
  7. java布尔值进行and和or逻辑运算原理
  8. jQuery动画高级用法(上)——详解animation中的.queue()动画队列插队函数
  9. Python如何实现单步调试
  10. json字符串对象内嵌json对象
  11. PAT1126:Eulerian Path
  12. Python DB operation
  13. python笔记13-文件读写
  14. [luogu3505][bzoj2088][POI2010]TEL-Teleportation【分层图】
  15. svn .a文件上传不了
  16. Fiddler 简单介绍
  17. [转]HashMap,LinkedHashMap,TreeMap的区别
  18. ArcGIS案例学习笔记-CAD数据自动拓扑检查
  19. msf客户端渗透(八):持久后门,mimikatz使用,获取PHP服务器shell
  20. 【13】享元模式(FlyWeight Pattern)

热门文章

  1. linux pts/0的含义
  2. Complete The Pattern #1
  3. (转载)有关反演和gcd
  4. 十个拥有丰富UI组件的JS开发框架
  5. windows获取窗口句柄
  6. [swustoj 1094] 中位数
  7. TCP编程(七)
  8. 让Codeigniter控制器支持多级目录
  9. YQL
  10. 【转】Android项目中编译 C的模块