Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12521    Accepted Submission(s): 8838
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.



"The second problem is, given an positive integer N, we define an equation like this:

  N=a[1]+a[2]+a[3]+...+a[m];

  a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

  4 = 4;

  4 = 3 + 1;

  4 = 2 + 2;

  4 = 2 + 1 + 1;

  4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 
Sample Input
4
10
20
 
Sample Output
5
42
627

整数拆分无限取,跟着包子做的题,就当做模板来用吧。

#include <stdio.h>
#define maxn 122 int c1[maxn], c2[maxn]; int main()
{
int n, i, j, k;
while(scanf("%d", &n) != EOF){
for(i = 0; i <= n; ++i){
c1[i] = 1; c2[i] = 0;
}
for(i = 2; i <= n; ++i){
for(j = 0; j <= n; ++j)
for(k = j; k <= n; k += i)
c2[k] += c1[j];
for(k = 0; k <= n; ++k){
c1[k] = c2[k]; c2[k] = 0;
}
}
printf("%d\n", c1[n]);
}
return 0;
}

最新文章

  1. 关于去除Eclipse对JavaScript的验证
  2. DIOCP之编写第一个应用程序(一)
  3. 如何使用jquery - ui 的图标icons 及图标的相对位置 +jquerui是如何来显示图标的?
  4. RabbitMq 应用
  5. React笔记_(6)_react语法5
  6. 推荐:根据ISBN号查询图书信息的API - 豆瓣API
  7. mysql启动停止,一台服务器跑 多个mysql数据库
  8. Oracle中使用escape关键字实现like匹配特殊字符,以及&amp;字符的转义
  9. quoit design(hdoj p1007)
  10. MVC 分页1 标准的url分页
  11. sealed、new、virtual、abstract与override 总结
  12. 洛谷U19464 山村游历(Wander)(LCT,Splay)
  13. css的em是根据什么来写的
  14. CSS的基本语法
  15. 编程菜鸟的日记-初学尝试编程-编写函数实现strcmp功能
  16. php上传图片预览,放大,裁剪
  17. 查看电脑的IP地址及配置
  18. Windows下用curl命令
  19. Python-flask跨站请求伪造和跨站请求保护的实现
  20. PAT 2016 数据的交换输出

热门文章

  1. hdu 1527(威佐夫博奕)
  2. 自定义View实现图片的绘制、旋转、缩放
  3. IRequiresSessionState和IReadOnlySessionState应用上的一些差异
  4. 笔记《Java程序性能优化 让你的Java程序更快、更稳定》 第二章 设计调优
  5. jquery自动将form表单封装成json的具体实现
  6. 任务(Tasks)
  7. js_sl 延迟菜单
  8. InfiniBand
  9. Application_Error
  10. Docker 入门教程(转)