Palindrome

Time Limit: 15000MS

Memory Limit: 65536K

Total Submissions: 12214

Accepted: 4583

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?"

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not.

The students recognized that this is a classical problem but couldn't come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said "Okay, I've a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I've an even better algorithm!".

If you think you know Andy's final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity).

Output

For each test case in the input print the test case number and the length of the largest palindrome.

Sample Input

abcbabcbabcba

abacacbaaaab

END

Sample Output

Case 1: 13

Case 2: 6

题解

求解最长回文子串的长度

本来是想练hash的,思路:hash+二分,时间复杂度\(O(T*len*log(len))\),其中T为组数,最大为30,len最大为1e6,肯定是过不了的,但是抱着既然是练习hash的心请,多打几遍也没事.然后就硬着头皮写下去,结果一个上午没有调出来,天衣无缝~~~

然后我含恨而去,学习了manacher,发现挺简单的,想学习的推荐博客super_hyper(真的很好理解,讲得很好)

原代码我一定会调出来的

Code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define Min(a,b) (a)<(b)?(a):(b)
#define Max(a,b) (a)>(b)?(a):(b)
#define in(i) (i=read())
using namespace std;
int read() {
int ans=0,f=1; char i=getchar();
while(i<'0' || i>'9') {if(i=='-') f=-1; i=getchar();}
while(i>='0' && i<='9') {ans=(ans<<1)+(ans<<3)+i-'0'; i=getchar();}
return ans*f;
}
int n;
char s[1000010],s_new[2000010];
int p[2000010];
int init() {
int len=strlen(s),j=2;
s_new[0]='$'; s_new[1]='#';
for(int i=0;i<len;i++) {
s_new[j++]=s[i];
s_new[j++]='#';
}
s_new[j]='\0';
return j;
}
int Manacher() {
int len=init();
int max_len=-1,id,mx=0;
for(int i=1;i<len;i++) {
if(i<mx) p[i]=Min(p[2*id-i],mx-i);
else p[i]=1;
while(s_new[i-p[i]]==s_new[i+p[i]]) p[i]++;
if(mx<i+p[i]) {
id=i; mx=i+p[i];
}
max_len=Max(max_len,p[i]-1);
}
return max_len;
}
int main()
{
int cnt=0;
while(1) {
cnt++;
scanf("%s",s);
if(s[0]=='E' && s[1]=='N' && s[2]=='D') break;
printf("Case %d: %d\n",cnt,Manacher());
memset(s,0,sizeof(s));
}
return 0;
}

博主蒟蒻,随意转载.但必须附上原文链接

http://www.cnblogs.com/real-l/

最新文章

  1. 备忘:aliyun maven mirror
  2. Ruby注意事项
  3. Windows下提升进程权限
  4. Microsoft Visual Studio 2013 VSTS单元测试指南
  5. 联系旭日150安装CentOS5.X版本手记
  6. BEvent_标准控件Event的用法(案例)(待整理)
  7. Lua利用cjson读写json示例分享
  8. [转] Android学习系列(29)--App调试的几个命令实践
  9. C++异常处理小例
  10. 【亲测】Python:解决方案:Python Version 2.7 required, which was not found in the registry
  11. 开涛spring3(6.6) - AOP 之 6.6 通知参数
  12. ng机器学习视频笔记(十六) ——从图像处理谈机器学习项目流程
  13. Scala之eq,equals,==的区别
  14. 多媒体文件格式(三):M3U8 格式
  15. CentOS下安装nvm
  16. Docker Kubernetes 环境搭建
  17. [UE4]保存玩家列表
  18. 清除 Xcode 项目缓存
  19. IOS成长之路-Xcode cannot run using the selected device. 解决办法
  20. WPF 的 ElementName 在 ContextMenu 中无法绑定成功?试试使用 x:Reference!

热门文章

  1. 第三章 最简单的C程序设计——顺序程序设计
  2. go学习笔记-运算符
  3. 【C#】 引用类型
  4. 【jQuery】 实用 js
  5. c++ combination by next_permutation
  6. SGU刷题之路,开始了
  7. Linux上jdk的安装(CentOS6.5)
  8. es6严格模式需要注意的地方
  9. Python登录小程序
  10. [leetcode-644-Maximum Average Subarray II]