题目描述

在一年前赢得了小镇的最佳草坪比赛后,Farm John变得很懒,再也没有修剪过草坪。现在,新一轮的最佳草坪比赛又开始了,Farm John希望能够再次夺冠。

然而,Farm John的草坪非常脏乱,因此,Farm John只能够让他的奶牛来完成这项工作。Farm John有N(1 <= N <= 100,000)只排成一排的奶牛,编号为1...N。每只奶牛的效率是不同的,奶牛i的效率为E_i(0 <= E_i <= 1,000,000,000)。

靠近的奶牛们很熟悉,因此,如果Farm John安排超过K只连续的奶牛,那么,这些奶牛就会罢工去开派对:)。因此,现在Farm John需要你的帮助,计算FJ可以得到的最大效率,并且该方案中没有连续的超过K只奶牛。

输入输出格式

输入格式:

第一行:空格隔开的两个整数 N 和 K

第二到 N+1 行:第 i+1 行有一个整数 E_i

输出格式:

第一行:一个值,表示 Farm John 可以得到的最大的效率值。

输入输出样例

输入样例#1:
复制

5 2
1
2
3
4
5
输出样例#1: 复制

12
设 dp[x]表示不选 x 位置时最大值;
则 对于 i-k-1<=j<=i-1,必有一处不选;

注意到此时处理完前缀和后,可以优化dp;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 200005
#define inf 0x7fffffff
//#define INF 1e18
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-5
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii; inline int rd() {
int x = 0;
char c = getchar();
bool f = false;
while (!isdigit(c)) {
if (c == '-') f = true;
c = getchar();
}
while (isdigit(c)) {
x = (x << 1) + (x << 3) + (c ^ 48);
c = getchar();
}
return f ? -x : x;
} ll gcd(ll a, ll b) {
return b == 0 ? a : gcd(b, a%b);
}
int sqr(int x) { return x * x; } /*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
if (!b) {
x = 1; y = 0; return a;
}
ans = exgcd(b, a%b, x, y);
ll t = x; x = y; y = t - a / b * y;
return ans;
}
*/
int n, k;
int e[maxn];
ll sum[maxn];
ll dp[maxn];
int l, r;
ll q[maxn];
int main()
{
//ios::sync_with_stdio(0);
n = rd(); k = rd();
for (int i = 1; i <= n; i++)e[i] = rd(), sum[i] = sum[i - 1] + 1ll * e[i];
l = 1, r = 1;
for (int i = 1; i <= n + 1; i++) {
while (l <= r && q[l] < i - k - 1)l++;
dp[i] = dp[q[l]] + sum[i - 1] - sum[q[l]];
while (l <= r && dp[q[r]] - sum[q[r]] <= dp[i] - sum[i])r--;
q[++r] = i;
}
cout << 1ll * dp[n + 1] << endl;
return 0;
}

最新文章

  1. 深入理解javascript函数参数与闭包(一)
  2. Subsets
  3. Preference Screen 首选项
  4. 十分钟搞定CSS选择器
  5. WinStore开发知识导航集锦
  6. MHA 日常管理
  7. How to: Hide the Ribbon in SharePoint 2010
  8. perl 获取阿里云主机信息
  9. &quot;浏览器端&quot; 使用 commonjs 模块规范开发网页应用,像开发 node 那样开发网页应用
  10. 第四章:Oracle12c 数据库在linux环境安装
  11. Collections类
  12. IE在开发工具启动的情况下(打开F12)时 JS才能执行
  13. JDBC---Mysql(2)
  14. MyBatis基础入门《九》ResultMap自动匹配
  15. 二十四、JAVA的NIO和IO的区别
  16. Java 导出 CSV
  17. 【python】python读取文件报错UnicodeDecodeError: &#39;gbk&#39; codec can&#39;t decode byte 0xac in position 2: illegal multibyte sequence
  18. spring-boot-jpa 自定义查询工具类
  19. ACCESS_TOKEN与FRESH_TOKEN
  20. SpringBoot两种读取配置文件的方式

热门文章

  1. 【转】OpenGL随笔(1)—— mipmap 详解
  2. sftp put权限不够
  3. C语言语法目录二
  4. 带你剖析WebGis的世界奥秘----瓦片式加载地图(转)
  5. Python3.7安装Django
  6. ROS naviagtion analysis: costmap_2d--LayeredCostmap
  7. SQL Server 本地时间和UTC时间的相互转换
  8. bash/shell的字符串trim实现
  9. ASP.NET框架获取数据字典数据做成树的格式
  10. Hadoop深入学习:MapTask详解