Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1221    Accepted Submission(s): 715

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score
of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3

3

3 3 3

10 5 1

3

1 3 1

6 2 3

7

1 4 6 4 2 4 3

3 2 1 7 6 5 4

Sample Output

0

3

5

解题心得:

1、这个题和普通的动态规划还是有差别的,它每一个元素都有一个截止日期,所以不能按照普通的动态规划来做。主要是想办法解决这个截止日期的问题。怎么在截止日期之内或得最多的分。

2、首先可以按照截止日期拍一个序,按照贪心的思想,肯定 是截止日期越前面的越先考虑。然后每一门课程从当前的截止日期开始往前面规划。在往前面规划的时候需要考虑一个问题,那就是当前是否已经安排满了。如果没有安排满,例如:第三天只安排了两天的作业,那么那门课程可以直接加在第三天上面就可以了,但是如果当天已经安排满了的情况下,就需要比较安排在当天的课程得分最少的那个和现在这门等待安排的课程比较哪个得分更多。如果当前得分大于已经安排了的的最少的得分,那么就将最少得分的那个减去,把现在这个安排进去。这个实现方法我想了一下,好像也只有使用优先队列,然后控制一下优先队列,这个题就很容易弄出来了。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1100;
struct sub
{
int dead;
int score;
friend bool operator <(sub a,sub b)
{
return a.score > b.score;
}
} su[maxn];
struct DP
{
int num;
int sum;
priority_queue <sub> qu;//dp数组里面的优先队列拿来记录这一天中安排的作业有哪些
}dp[maxn];
bool cmp(sub a,sub b)
{
return a.dead < b.dead;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int Max = 0;
int sum = 0;
int n,time = 0; //这个输入有点烦
scanf("%d",&n);
for(int i=1; i<=n; i++)
{
scanf("%d",&su[i].dead);
if(su[i].dead > time)
time =su[i].dead;
}
for(int i=0;i<=time;i++)
{
while(!dp[i].qu.empty())
dp[i].qu.pop();
dp[i].num = 0;
dp[i].sum = 0;
}
for(int i=1;i<=n;i++)
{
scanf("%d",&su[i].score);
sum += su[i].score;
} sort(su + 1,su + n + 1,cmp);//按照贪心的思想,从截止日期的先后进行排序
for(int i=1;i<=n;i++)
{
for(int j=su[i].dead;j>=1;j--)
{
if(dp[j].num < j && dp[j].sum < dp[j-1].sum + su[i].score)//当天没有安排满,就将这个作业直接安排在这一天
{
dp[j].sum = dp[j-1].sum + su[i].score;
dp[j].qu = dp[j-1].qu;
dp[j].qu.push(su[i]);
dp[j].num = dp[j-1].num + 1;
}
else if(dp[j].num == j && dp[j].sum < dp[j].sum - dp[j].qu.top().score + su[i].score)//当天安排满了,并且等待安排的这个作业比已经安排在这一天的作业中的最小的那个得分更高
{
dp[j].sum = dp[j].sum - dp[j].qu.top().score + su[i].score;
dp[j].qu.pop();
dp[j].qu.push(su[i]);
}
if(dp[j].sum > Max)//记录一下获得的最高的分
Max = dp[j].sum;
}
}
printf("%d\n",sum-Max);//总分减去最高的分就是被扣的最少的分
}
return 0;
}

最新文章

  1. entityframework学习笔记--002-database first
  2. C#基础---Attribute(标签) 和 reflect(反射) 应用
  3. Character类的2个定义大小写方法以及charAt(int index)方法
  4. css-css权威指南学习笔记1
  5. PLSQL 设置
  6. ios 项目被拒绝各种理由
  7. JVM学习之内存分配一
  8. MySQL线程池的引入可以提高我们的MySQL的性能
  9. Android 开发笔记___FrameLayout
  10. C#操纵Excel,此工作薄包含嵌入对象,Office 2007的设定方法
  11. sql*loader以及oracle外部表加载Date类型列
  12. id选择器为变量时
  13. MySQL数据库order by 奇慢无比
  14. Access restriction: The type Resource is not accessible due to restriction on required library
  15. 6.27-JSTL、标签、分页
  16. Android 蓝牙操作详解
  17. KNN理解
  18. 【最小割】【Dinic】Gym - 101201G - Maximum Islands
  19. JavaScript tips —— 搞定闰年
  20. Xamarin.Forms+Prism(2)—— 基本使用 NavigationService 相对路径和绝对路径

热门文章

  1. ElasticSearch java API-使用More like this实现基于内容的推荐
  2. vue-extend 选项
  3. logback的加载过程
  4. 9.26&lt;立方网&gt;技术笔试题
  5. Yii2 widgets [mztest/yii2-widget-file-upload]
  6. POJ 2392 Space Elevator(多重背包)
  7. mkfs.xfs 命令找不到的解决方法
  8. Airflow 调度基础
  9. 2018.1.4 UML 第三章 用例图
  10. SCSI add-single-device and remove-single-device