The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

KMP板子题

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm> using namespace std;
void kmp_pre(char x[],int m,int next[]) {
int i,j;
j=next[0]=-1;
i=0;
while(i<m) {
while(-1!=j && x[i]!=x[j])j=next[j];
next[++i]=++j;
}
}
int next[1000010];
int KMP_Count(char x[],int m,char y[],int n) { //x 是模式串,y 是主串
int i,j;
int ans=0;
//preKMP(x,m,next);
kmp_pre(x,m,next);
i=j=0;
while(i<n) {
while(-1!=j && y[i]!=x[j])j=next[j];
i++;
j++;
if(j>=m) {
ans++;
j=next[j];
}
}
return ans;
} char a[10005];
char b[1000005];
int main() { int T;
cin>>T;
while(T--) {
scanf("%s",a);
scanf("%s",b);
printf("%d\n",KMP_Count(a,strlen(a),b,strlen(b)));
} return 0;
}

最新文章

  1. C#网络编程——IPHostEntry
  2. bzoj3998: [TJOI2015]弦论
  3. Linux 输出重定向&gt;和&gt;&gt;的区别
  4. jquery.dataTable分页
  5. android firmware 利用UDP socket发送Magic Packet--python版本
  6. bzoj 2659: [Beijing wc2012]算不出的算式
  7. springMVC中一个class中的多个方法
  8. [Phonegap+Sencha Touch] 移动开发34 gem安装compass,不编译scss,怎么办?
  9. 拥抱Node.js 8.0,N-API入门极简例子
  10. 03标准对象-01-Date和JSON
  11. Unity3D - Animator Controller循环依赖
  12. g4e基础篇#2 Git分布式版本控制系统的优势
  13. python原始字符串
  14. JAVA中pdf转图片的方法
  15. 第三章Hibernate关联映射
  16. PowerShell工作流学习-7-编写脚本工作流帮助
  17. neutron 多租户隔离的实现以及子网间路由的实现
  18. crawlspider_房多多
  19. 关于tomcat7服务下面js无法获取JSESSIONID的cookie信息
  20. SSIS 包配置

热门文章

  1. pthon之函数式编程
  2. 剑指offer 38_统计数组中k出现的个数
  3. spring----AOP注解以及spring的JDBC和事务
  4. Angular07 利用angular打造管理系统页面
  5. Linux,du、df统计的硬盘使用情况不一致问题
  6. 算法Sedgewick第四版-第1章基础-014一用stack把前置表达式转为后置表达式并计算值
  7. poj2287 Tian Ji -- The Horse Racing
  8. java全栈day02案例
  9. ListBox 光标如何定位在最后一行 显示
  10. 《Head First Servlets & JSP》-6-会话管理