/*Fibbonacci Number

Problem Description

Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0

f(1) = 1

f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

Input

Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.

Output

Print out the answer in a single line for each test case.

Sample Input

3

4

5

-1

Sample Output

2

3

5

you can use 64bit integer: __int64
*/
#include<cstdio>
#include<string.h>
__int64 s[100]={0,1,0};
int main()
{
int n,i;
while(~scanf("%d",&n),n!=-1)
{
for(i=2;i<=n;i++)
{
s[i]=s[i-1]+s[i-2];
}
printf("%I64d\n",s[n]);
}
return 0;
}

最新文章

  1. ArcMap Add-in插件开发中解决VS调试时断点不会命中的问题
  2. 无废话SharePoint入门教程二[SharePoint发展、工具及术语]
  3. [CareerCup] 16.4 A Lock Without Deadlocks 无死锁的锁
  4. GDC2016【全境封锁(Tom Clancy&#39;s The Division)】对为何对应Eye Tracked System,以及各种优点的演讲报告
  5. Jquery判断离开页面时,通过Ajax更新数据(兼容IE,Chrome,FF浏览器)
  6. MapReduce读取hdfs上文件,建立词频的倒排索引到Hbase
  7. hdu 1437 天气情况【概率DP】
  8. RestServer 1.1发布
  9. php知识点总结(一)
  10. JavaScript对象之document对象
  11. WPF中实现多选ComboBox控件
  12. Linux硬链接和软连接详解
  13. 获取对象属性类型、属性名称、属性值的研究:反射和JEXL解析引擎
  14. Codeforces Round #436 (Div. 2)D. Make a Permutation! 模拟
  15. 20165213&amp;20165225结对学习感想及创意照
  16. Python(多进程multiprocessing模块)
  17. 洛咕 P3964 [TJOI2013]松鼠聚会
  18. CAS 5.1.x 的搭建和使用(一)—— 通过Overlay搭建服务端
  19. HTML学习---HTTP基础学习详解
  20. 【计算几何】【bitset】Gym - 101412G - Let There Be Light

热门文章

  1. Linux - 目录结构与查看,复制,删除,剪切指令
  2. php简单表格函数
  3. php navigat备份
  4. 带中横线的日期格式在iOS手机系统上 转换时间戳NaN问题
  5. SEO规范(部分)
  6. 如何解决Android 5.0以上出现的警告:Service Intent must be expli
  7. [ Java ] String 轉型 ArrayList
  8. Verilog之$sreadmemb
  9. 实践:使用FLANN.LSH进行检索
  10. 【技术累积】【点】【java】【2】聊一聊似曾相识的switch语句