Wooden Sticks





Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11244    Accepted Submission(s): 4627

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:




(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.




You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.
 
Output
The output should contain the minimum setup time in minutes, one per line.
 
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
 
Sample Output
2
1
3

题意是第一个3是3组数据, 然后一个5是5根棍子。 然后逐一输入其的长度和重量。

。题目是问怎么做这些棍子用时最少,在做棍子时。若后一根棍子。长度和重量都大于前

一根。则不用加时间。。

想法。。

拿第一组数据来说。

首先按长度以小到大排序:(1,4),(2,1),(3。 5)。 (4, 9),(5,2);

我们发现(2。 1)的重量太小, 而(5, 2)的长度太长。这样排结果为3;

事实上这时,我们仅仅要把不满足的先标记起来。

则(1,4)。(3,5),(4,9)      ————     (2,1), (5,2)

但我们这么排, 也就是题目给出的顺序,结果就为2;也就是最优。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<sstream>
#include<cmath> using namespace std; #define M 100500 struct node
{
int lenth;
int weight;
int k;
} Q[M]; bool cmp ( node a, node b )
{
if(a.lenth==b.lenth)
return a.weight<b.weight;
else
return a.lenth<b.lenth;
} int main()
{
int t;
int n;
scanf("%d", &t);
while( t-- )
{
scanf("%d", &n);
for(int i=0; i<n; i++)
{
scanf("%d%d", &Q[i].lenth, &Q[i].weight);
Q[i].k= 1;
}
sort( Q, Q+n, cmp );
int ans = 0;
for(int i=0; i<n-1; i++)
{
if(!Q[i].k)
continue;
int t = Q[i].weight;
for(int j = i+1; j<n; j++)
if(Q[j].weight>=t &&Q[j].k==1 )
{
ans++;
Q[j].k=0;
t = Q[j].weight;
}
}
printf("%d\n", n-ans);
} return 0;
}

最新文章

  1. Tomcat调试笔记
  2. Python 集合set添加删除、交集、并集、集合操作符号
  3. php注意事项
  4. ActiveMQ第四弹:在HermesJMS中创建ActiveMQ Session
  5. java如何连接testlink
  6. (5)html表单
  7. axure rp pro 6.5 注册码
  8. Java知识总结--CoreJava
  9. Matlab read_grib.r4 安装新方法(转自:http://blog.sina.com.cn/s/blog_9f36648b010179s7.html)
  10. knockout.js简单实用教程1
  11. Python学习之路——初识Python
  12. 一次ORA-03113错误解决
  13. PHPCMS 概念初学
  14. Sublime Text 3 修改配色主题【侧边框之...】
  15. Jackson注解学习参考(转)
  16. c语言字符相关函数
  17. manjaro备忘录
  18. Linux安装NodeJS
  19. @ConfigurationProperties + @EnableConfigurationProperties
  20. POJ2228 Naptime

热门文章

  1. Redis源代码分析(二十二)--- networking网络协议传输
  2. jquery源码ajax分析
  3. Suffix Array 后缀数组
  4. UVA - 1471 Defense Lines 树状数组/二分
  5. Blur 算法 (Unity 5.0 Shader)
  6. 升级Xcode8后的相机crash问题-IOS10权限问题
  7. 大话主席(superslide和 touchslide)插件的使用
  8. Springboot use tomcat JNDI
  9. PHP学习过程中遇到的疑难杂症
  10. SVG矢量动画