Time Limit: 3000MS   Memory Limit: 131072KB   64bit IO Format: %lld & %llu

Submit
Status

Description

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from
N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level
A and B form a team, the skill level of the team will be
A
B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e.
AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer
T
indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains
N positive integers separated by spaces. The ith integer denotes the skill level of
ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

Hint

Source

The 12th Zhejiang Provincial Collegiate Programming Contest
神奇的位运算

#include<cstdio>
#include<cstring>
int a[100100];
int num[40];
void sum(int x)
{
int pos=31;
while(pos>=0)
{//1左移31位,&同为1时为1,其他为0
if(x&(1<<pos))//寻找最高的二进制位
{
num[pos]++;
return ;
}
pos--;
}
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
memset(num,0,sizeof(num));
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum(a[i]);
}
long long ans=0;
for(int i=0;i<n;i++)
{
int pos=31;
while(pos)
{
if(a[i]&(1<<pos))
break;
pos--;
}
while(pos>=0)
{
if(!(a[i]&(1<<pos)))
ans+=num[pos];//num中存储的最高位为pos的数的个数
pos--;
}
}
printf("%lld\n",ans);
}
return 0;
}

最新文章

  1. ImageLoader
  2. Android中什么时候使用get和post 以及他们的优缺点!!
  3. Stamps and Envelope Size
  4. PureCSS框架
  5. hdu 4641 K-string SAM的O(n^2)算法 以及 SAM+并查集优化
  6. Unity3d中所有特殊的文件夹
  7. 非正式js语法
  8. NAS4Free 安装配置 -- 目录
  9. cmake 学习笔记(三)
  10. toFixed()要注意的
  11. 白话大数据 | Spark和Hadoop到底谁更厉害?
  12. python subprocess.Popen 控制台输出 实时监控百度网ping值
  13. Codeforces Round 504
  14. phabricator 结合 arcanist 使用
  15. VS2010调试多进程
  16. PHP-002
  17. Jmeter 建立数据库测试计划
  18. Ubuntu 14.04.5 imx6 开发环境搭建
  19. Nodejs连接数据库为何使用连接池
  20. Java_WebKit

热门文章

  1. STL之string篇
  2. Miller Rabin 大素数测试
  3. oracle 入门笔记--v$sql和v$sqlarea视图(转载)
  4. JAVA中EXTENDS 与 IMPLEMENT 区别
  5. CDR服装设计-用CorelDRAW排钻如何把圈摆均匀
  6. NOIWC2019 冬眠记
  7. js 图表转图片
  8. Vim 写 C/C++ 的配置
  9. php 导出Excel 不用安装插件、开启配置
  10. django访问静态变量的设置