A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5

1 2 2

1 4 2

1 G1 4

1 G2 3

2 3 2

2 G2 1

3 4 2

3 G3 2

4 G1 3

G2 G1 1

G3 G2 2

Sample Output 1:

G1

2.0 3.3

Sample Input 2:

2 1 2 10

1 G1 9

2 G1 20

Sample Output 2:

No Solution

分析

可以看出这题是图的最短路径,可用Dijkstra算法去解决,但要注意把Gxxx转化为数字。

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int inf=9999999;
int G[1024][1024],visited[1024]={0},dist[1024]={inf},n,m,k,dis;
int main(){
fill(G[0],G[0]+1024*1024,inf);
fill(dist,dist+1024,inf);
cin>>n>>m>>k>>dis;
for(int i=0;i<k;i++){
string s1,s2;
int a,b,tempdis;
cin>>s1>>s2>>tempdis;
if(s1[0]=='G'){
s1=s1.substr(1);
a=n+stoi(s1);
}else{
a=stoi(s1);
}
if(s2[0]=='G'){
s2=s2.substr(1);
b=n+stoi(s2);
}else{
b=stoi(s2);
}
G[a][b]=G[b][a]=tempdis;
}
int ansid = -1;
double ansdis = -1, ansaver = inf;
for(int index=n+1;index<=n+m;index++){
double mindis=inf,aver=0;
fill(dist,dist+1024,inf);
fill(visited,visited+1024,0);
dist[index]=0;
for(int j=0;j<n+m;j++){
int min=inf,temp=-1;
for(int i=1;i<=n+m;i++)
if(visited[i]==0&&dist[i]<min){
temp=i;
min=dist[i];
}
if(temp==-1) break;
visited[temp]=1;
for(int i=1;i<=n+m;i++){
if(visited[i]==0&&dist[i]>dist[temp]+G[temp][i])
dist[i]=dist[temp]+G[temp][i];
}
}
for(int i=1;i<=n;i++){
if(dist[i] > dis) {
mindis = -1;
break;
}
if(dist[i] < mindis) mindis = dist[i];
aver += 1.0 * dist[i];
}
if(mindis == -1) continue;
aver = aver / n;
if(mindis > ansdis) {
ansid = index;
ansdis = mindis;
ansaver = aver;
} else if(mindis == ansdis && aver < ansaver) {
ansid = index;
ansaver = aver;
}
}
if(ansid == -1)
printf("No Solution");
else
printf("G%d\n%.1f %.1f", ansid - n, ansdis, ansaver);
return 0;
}

最新文章

  1. 【Java每日一题】20161214
  2. Qt之布局管理--基本布局
  3. Ajax1
  4. hdu 4576 概率dp **
  5. bzoj 2751 [HAOI2012]容易题(easy)(数学)
  6. pro asp.net mvc5 7
  7. python array 使用创建10万浮点数
  8. STM32中断优先级彻底讲解
  9. Confluence 6 使用 Apache 和 mod_proxy 的基本配置
  10. Java第一次作业——Java语言基础
  11. 编写xml文件不当时会出现R文件找不到情况
  12. 雷林鹏分享:XML to HTML
  13. @1-2初识Python爬虫
  14. Grep学习笔记
  15. ArcEngine和GDAL读写栅格数据机制对比(一)
  16. (转载)YOLO配置文件理解
  17. centos ssh免密码秘钥登录
  18. webpack---less+热更新 使用
  19. MYSQL复习笔记10-连接
  20. 将HTML元素转换成图片供用户下载(html2canvas + canvas2Image)

热门文章

  1. HotSpotVM 线程实现浅析
  2. Yslow on Nodejs server
  3. Mybatis 碰到的一些问题
  4. poi读取docx中的文字和图片(自己应用)
  5. oracle buffer cache的基本原理
  6. B1024 生日快乐 递归。。。
  7. XML案例(使用JAXP进行DOM解析)
  8. linux下安装rabbitmq以及在spring中进行集成
  9. C#中动态读取配置
  10. JavaScript 进阶 常用内置对象