DNA Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2357    Accepted Submission(s): 1158

Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters
to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is
as unsorted as can be--exactly the reverse of sorted).



You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.





This problem contains multiple test cases!



The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.



The output format consists of N output blocks. There is a blank line between output blocks.


 
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string
of length n.
 
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.

 
Sample Input
1 10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
 
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
 
记得大一暑假的时候看到这个题也是一脸的懵逼
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
char s[55];
int num,p;
}q[1010];
bool cmp(node s1,node s2)
{
if(s1.p==s2.p)
return s1.num<s2.num;
return s1.p<s2.p;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=0;i<m;i++)
{
scanf("%s",q[i].s);
q[i].num=i;
q[i].p=0;
for(int j=0;j<n;j++)
{
for(int k=j+1;k<n;k++)
{
if(q[i].s[j]>q[i].s[k])
{
q[i].p++;
}
}
}
}
sort(q,q+m,cmp);
for(int i=0;i<m;i++)
printf("%s\n",q[i].s);
}
return 0;
}

最新文章

  1. cocos2d-x 3.10 PageView BUG
  2. C# 去掉List重复元素的方法
  3. XML.01-语法简介
  4. (转载)IE6支持透明PNG图片解决方案:DD_belatedPNG.js
  5. Tomcat访问日志详细配置
  6. 很多k线形态或k线组合是需要验证的
  7. Nhibernate 分页功能
  8. 在Windows环境下使用MinGW编译Qt 4.8.6
  9. [Unity3D]Unity3D游戏开发之刀光剑影特效的实现
  10. 【LeetCode】217. Contains Duplicate
  11. 说说 typedef 的那些事
  12. aspnet mvc 中 跨域请求的处理方法
  13. TP无限回复
  14. Kubernetes1.8以后kubelet连接api-server问题
  15. android 开发 实现多个动态权限的方法(并且兼容6.0以下的版本权限授权)
  16. MongoDb GridFS的使用
  17. [WPF打印]WPF 文档元素(Run TextBlock Paragraph)的文字对齐方式
  18. 9-[CSS]-字体、文本、背景图片
  19. 1z0-052 q209_7
  20. 2017-2018 ACM-ICPC East Central North America Regional Contest (ECNA 2017) Solution

热门文章

  1. CentOS 6, 编译安装lamp (php-fpm)
  2. auto_ptr 实现
  3. MFC对话框使用CPrintDialog实现打印,指定打印机、后台打印
  4. 大数据平台消息流系统Kafka
  5. Qt Widgets Application可执行程序发布方式
  6. 61. mybatic insert异常:BindingException: Parameter 'name' not found【从零开始学Spring B】
  7. tyvj1031 热浪
  8. 【Github】如何删除github上的项目
  9. 选择器的使用(empty选择器)
  10. Android 原生开发、H5、React-Native使用利弊和场景技术分享