Pocky
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2095 Accepted Submission(s): 1133

Problem Description
Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input
The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output
For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input
6
1.0 1.0
2.0 1.0
4.0 1.0
8.0 1.0
16.0 1.0
7.00 3.00

Sample Output
0.000000
1.693147
2.386294
3.079442
3.772589
1.847298

#include <bits/stdc++.h>
using namespace std;
int main()
{
int t;
double l,d;
scanf("%d",&t);
while(t--){
scanf("%lf%lf",&l,&d);
if(l<=d){
printf("0.000000\n");
}
else{
printf("%.6f\n",+log(l/d));
}
}
return ;
}

最新文章

  1. 创建JOB
  2. CheckListBox的实现方式分析
  3. 汇文Libsys图书管理系统全版本权限绕过+getshell
  4. AD采样问题总结
  5. WCF 内存入口检查失败
  6. ES6新增Promise
  7. 做一个聪明的.net程序员
  8. Windows平台下为Python添加MySQL支持
  9. Database API
  10. Android 设置隐式意图
  11. Makefile与shell脚本区别
  12. ubuntu下命令使用
  13. 安装WIA组件
  14. cookie设置和清除,解决跨目录读取不到cookie值
  15. 正则表达式工具RegexBuddy
  16. 通过apicloud实现的混合开发App的Demo
  17. c#之根据出生日期获得星座信息
  18. 案例1:写一个压缩字符串的方法,例如aaaabbcxxx,则输出a4b2c1x3。
  19. Python面试 【315+道题】
  20. CMake Error: Curses library not found. Please install appropriate package

热门文章

  1. 无线网路由器的dBm值
  2. (转)nginx利用geo模块做限速白名单以及geo实现全局负载均衡的操作记录
  3. CM5.7.2 yum离线安装笔记
  4. P3290 寻找第K大数
  5. HTTP状态码完整版
  6. Fleet-运行一个高可用的服务
  7. 7.Solution的Build、Rebuild和Clean
  8. elasticsearch dump加过滤条件(--searchBody)出错的解决 Unexpected token &#39; in JSON at position 0
  9. edittext 设置不自动获取焦点
  10. Linux 安装Memcache扩展支持