题目信息

1069. The Black Hole of Numbers (20)

时间限制100 ms

内存限制65536 kB

代码长度限制16000 B

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

7641 - 1467 = 6174

… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

解题思路

直接计算就可以

AC代码

#include <cstdio>
#include <algorithm>
using namespace std;
int getmin(int a){
int t[4] = {0}, c = 0;
while (a){
t[c++] = a%10;
a /= 10;
}
sort(t, t + 4);
c = 0;
while (c < 4){
a = a*10 + t[c++];
}
return a;
}
int getmax(int a){
int t[4] = {0}, c = 0;
while (a){
t[c++] = a%10;
a /= 10;
}
sort(t, t + 4, greater<int>());
c = 0;
while (c < 4){
a = a*10 + t[c++];
}
return a;
} int main()
{
int a;
scanf("%d", &a);
while (true){
int mn = getmin(a);
int mx = getmax(a);
printf("%04d - %04d = %04d\n", mx, mn, mx - mn);
a = mx - mn;
if (a == 6174 || mn%10 == mn/1000) break;
}
return 0;
}

个人游戏推广:

《10云方》与方块来次消除大战!

最新文章

  1. 如何在Node.js中合并两个复杂对象
  2. 如何使用VS在SharePont 2013中插入ashx文件
  3. Ubuntu下安装Koala
  4. jQuery ajax - getScript() 方法和getJSON方法
  5. 重读LPTHW-Lesson37
  6. Python collections.defaultdict 笔记
  7. CSS未知div高度垂直居中代码_层和布局特效
  8. HTML&amp;CSS Table元素详细解说
  9. 限制input[type=number]的输入位数策略整理
  10. href
  11. c#下winform的ftp上传
  12. 熊猫猪新系统测试之三:iOS 8.0.2
  13. “Axure”介绍
  14. day26:静态方法,类方法和反射
  15. 【LeetCode每天一题】Merge Two Sorted Lists(合并两个排序链表)
  16. String拼接
  17. Find 和 Findstr
  18. Kafka consumer的参数
  19. Java-数组队列
  20. Android Studio添加assets文件夹

热门文章

  1. Android学习路线(十四)Activity生命周期——停止和重新启动(Stopping and Restarting)一个Activity
  2. Leetcode:populating_next_right_pointers_in_each_node题解
  3. Xcode6:No architectures to compile for(ONLY_ACTIVE_ARCH=YES...)
  4. 文件上传流式处理commons-fileupload
  5. Android 利用代码在屏幕中间位置显示ProgressDialog和ProgressBar
  6. 使用Docker来运行WebApp
  7. 看&lt;Asp.net夜话&gt;随笔(2013-10-13)
  8. VC error link
  9. 【MemSQL Start[c]UP 3.0 - Round 1 B】 Lazy Security Guard
  10. [Angular] Reactive Store and AngularFire Observables