Pet

                                                         Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

                                                                         Total Submission(s): 1909    Accepted Submission(s): 924


                                                                                                                             链接:

pid=4707">Click Me !

Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches
was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your
task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
Input
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations
in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
Sample Input
1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9
Sample Output
2
Source

题意:

给定N个点,标号为0~N-1,还有N-1条边,数据保证N-1条边不成环,也就是说,输入的节点为N的一棵树。根节点为0,要你求深度大于d的节点的数目。

分析:

从根节点0開始,BFS其全部的子节点。统计深度小于等于d的节点的数目cnt。那么答案就是N-cnt。水题~

#include <queue>
#include <cmath>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define FIN freopen("input.txt","r",stdin)
#define FOUT freopen("output.txt","w",stdout)
typedef long long LL;
const int MAXN = 1e6 + 50;
struct Node
{
vector<int> son;
} nodes[MAXN];
bool vis[MAXN];
void add_edge(int a, int b)
{
nodes[a].son.push_back(b);
} struct Fuck
{
int pos, step;
Fuck() {}
Fuck(int _p, int _s) : pos(_p), step(_s) {}
};
queue<Fuck> Que;
int Dis, N;
int BFS()
{
memset(vis,false,sizeof(vis));
int cnt = 0;
Fuck Now(0, 0);
Que.push(Now);
vis[0] = true;
while(!Que.empty())
{
Now = Que.front();
Que.pop();
int nowp = Now.pos, nows = Now.step;
if(nows == Dis) continue;
for(int i = 0; i < nodes[nowp].son.size(); i++)
{
int sonp = nodes[nowp].son[i];
if(vis[sonp]) continue;
Que.push(Fuck(sonp, nows + 1));
vis[sonp] = true;
cnt ++;
}
}
return N - cnt - 1;
}
int main()
{
// FIN;
int T;
scanf("%d", &T);
while(T--)
{
scanf("%d%d", &N, &Dis);
for(int i = 0; i < N; i++)
nodes[i].son.clear();
for(int i = 1; i <= N - 1; i++)
{
int a, b;
scanf("%d%d", &a, &b);
add_edge(a, b);
add_edge(b, a);
}
int ans = BFS();
printf("%d\n", ans);
}
return 0;
}

最新文章

  1. python中的GIL(全局解释锁)多线程能够提升效率
  2. Android中下载、安装和卸载(原)
  3. Asp.Net MVC4入门指南(10):第三方控件Studio for ASP.NET Wijmo MVC4 工具应用
  4. eclispe报错PermGen space
  5. HTTP状态码对照表 HTTP response codes
  6. git stash 暂存当前修改
  7. 《WPF程序设计指南》读书笔记——第8章 依赖属性
  8. 图片上传iOS
  9. C#基础|初探反射
  10. EA强大功能之代码凝视
  11. intellij idea 12 搭建maven web项目
  12. Modbus软件开发实战指南 之 开发自己的Modbus Poll工具 - 1
  13. DAX基础入门 - 30分钟从SQL到DAX -- PowerBI 利器
  14. elasticsearch系列(一) 术语
  15. Linux新增和删除环境变量
  16. npm 安装包失败 --- 清除npm缓存
  17. Linux 内核源代码根目录
  18. Deep Learning系统实训之二:梯度下降原理
  19. ECMAScript 6 入门之字符串
  20. unity实现一个物体绕着某点旋转

热门文章

  1. 关于zabbix 的lld的web界面的配置
  2. 前端学习之路——gulp篇
  3. express + multer 文件上传入门
  4. Unknown column &#39;t_user.id&#39; in &#39;where clause&#39;(通过字段名删除不了数据)
  5. 洛谷P3834 【模板】可持久化线段树 1 主席树
  6. 简洁的MVC思想框架——Nancy(Session的使用)
  7. luogu P2041 分裂游戏(结论题)
  8. Aspose WorkbookDesigner打开文件异常"Error xml namespace"
  9. 洛谷—— P1855 榨取kkksc03
  10. Windows下从源代码编译Skia