The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking. 
You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day. 

Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200. 

Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes. 

Sample Input

bbjd

Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb
全排列 开始不知道有全排列的函数,半天没写出来
#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
#define maxn 10010
using namespace std;
int main()
{
char str[];
while(cin >> str)
{
getchar();
sort(str,str+strlen(str));//排序
do
{
cout << str << endl;
}
while(next_permutation(str,str+strlen(str)));//全排列函数
}
return ;
}

最新文章

  1. ABP源码分析三十二:ABP.SignalR
  2. 所有HTTP请求参数及报文查看SERVLET
  3. React Native01-开始 Windows环境安装配置篇
  4. Print2flash在.NET(C#)中的使用,即文档在线预览
  5. 【LeetCode】18. 4Sum
  6. Silverlight自动根据屏幕分辨率进行布局
  7. 获取资源ID
  8. 33条C#、.Net经典面试题目及答案[zt]
  9. 关于php判断中文字符的问题
  10. 移植kl档,但调用默认Generic.kl解决的方法
  11. C# 图形普通处理,resize ,水印..
  12. 对于react中rredux的理解
  13. map获取数字与int比较
  14. 4889: [Tjoi2017]不勤劳的图书管理员 树套树
  15. 如何用VBA实现格式刷的功能?
  16. Blender设置界面语言
  17. Python之路(第一篇):Python简介和基础
  18. maven配置sqlServer的依赖
  19. NGINX源代码自我总结(一)
  20. 转:zTree树控件实战篇:针对多个下拉加载zTree树应该如何做出合理的配置

热门文章

  1. 关于程序null值的见解
  2. Linux基础文件类型
  3. Android 属性动画实战
  4. [Abp vNext 源码分析] - 7. 权限与验证
  5. 通过jmeter发送webservice接口请求
  6. 头部姿态估计 - Android
  7. HelloDjango 第 07 篇:创作后台开启,请开始你的表演!
  8. Linux--shell的基本特性--01
  9. ABAP 查看采购订单行项目已开票金额和已清金额
  10. canvas 鼠标位置缩放图形