http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2369

Description

Problem D: Airport Express

In a small city called Iokh, a train service, Airport-Express, takes residents to the airport more quickly than other transports. There are two types of trains in Airport-Express, the Economy-Xpressand the Commercial-Xpress.
They travel at different speeds, take different routes and have different costs.

Jason is going to the airport to meet his friend. He wants to take the Commercial-Xpress which is supposed to be faster, but he doesn't have enough money. Luckily he has a ticket for the Commercial-Xpress which can take him one station forward. If he used the
ticket wisely, he might end up saving a lot of time. However, choosing the best time to use the ticket is not easy for him.

Jason now seeks your help. The routes of the two types of trains are given. Please write a program to find the best route to the destination. The program should also tell when the ticket should be used.

Input

The input consists of several test cases. Consecutive cases are separated by a blank line.

The first line of each case contains 3 integers, namely NS and E (2 ≤ N ≤ 500, 1 ≤ SE ≤ N),
which represent the number of stations, the starting point and where the airport is located respectively.

There is an integer M (1 ≤ M ≤ 1000) representing the number of connections between the stations of the Economy-Xpress. The next Mlines give the information of the routes of the Economy-Xpress.
Each consists of three integers XY and Z (XY ≤ N, 1 ≤ Z ≤ 100). This means X and Y are
connected and it takes Z minutes to travel between these two stations.

The next line is another integer K (1 ≤ K ≤ 1000) representing the number of connections between the stations of the Commercial-Xpress. The next K lines contain the information of
the Commercial-Xpress in the same format as that of the Economy-Xpress.

All connections are bi-directional. You may assume that there is exactly one optimal route to the airport. There might be cases where you MUST use your ticket in order to reach the airport.

Output

For each case, you should first list the number of stations which Jason would visit in order. On the next line, output "Ticket Not Used" if you decided NOT to use the ticket; otherwise, state the station where Jason should get on the train
of Commercial-Xpress. Finally, print the total time for the journey on the last line. Consecutive sets of output must be separated by a blank line.

Sample Input

4 1 4
4
1 2 2
1 3 3
2 4 4
3 4 5
1
2 4 3

Sample Output

1 2 4
2
5

Problemsetter: Raymond Chun

Originally appeared in CXPC, Feb. 2004


题目大意:

机场快线分为经济线和商业线。两种路线价格、路线、速度不同。给你初始地点和目标地点,还有所有的经济线和商业线,要你求出从到目标地点最快的路线,这条路线有一个要求就是最多坐一条商业线,当然也可以不做,速度最快就好。

要求输出所经过的路径、在哪个站点使用商业线、以及总的时间。

思路:

我们可以先调用两次dijkstra或者两次SPFA,求出起点和终点到所有点的最短路径,然后商业线一一枚举。

example:

INPUT:

5 5 1

3

1 2 4

2 3 4

3 4 4

5

1 2 2

2 3 2

1 3 2

2 4 2

4 5 10

OUT:

5 4 3 2 1

5

22

判断商业线的时候,要特别注意。看下面的代码,要判断双向的。我一开始一直WA就是这样。。

dijkstra版本:0.019s

#include<cstdio>
#include<cstring>
#include<queue>
const int INF=999999;
const int MAXN=520;
const int MAXM=2520;
using namespace std;
struct edge
{
int to;
int val;
int next;
}e[MAXM]; struct node
{
int from;
int val;
node(int f,int v){from=f;val=v;}
bool operator < (const node& b)const
{
return val > b.val;
}
}; int head[MAXN],len;
int dis_s[MAXN],dis_r[MAXN],path_s[MAXN],path_r[MAXN]; void add(int from,int to,int val)
{
e[len].to=to;
e[len].val=val;
e[len].next=head[from];
head[from]=len++;
} int n,s,en;
void dijkstra(int start,int dis[],int path[])
{
bool vis[MAXN]={0};
dis[start]=0; priority_queue<node> q;
q.push(node(start,0));
int num=0;
while(!q.empty())
{
node temp=q.top();
q.pop(); if(vis[temp.from])
continue; vis[temp.from]=true; if(num==n)
break;
for(int i=head[temp.from];i!=-1;i= e[i].next)
{
if( !vis[e[i].to] &&
dis[temp.from] + e[i].val < dis[e[i].to])
{
dis[e[i].to]=dis[temp.from] + e[i].val ;
path[e[i].to] = temp.from;
q.push(node(e[i].to,dis[e[i].to]));
}
}
}
} void print(int cur)
{
if(path_s[cur]!=-1)
print(path_s[cur]); if(cur!=en)
printf("%d ",cur);
else
printf("%d\n",cur);
}
int main()
{
bool not_first=false;
while(~scanf("%d%d%d",&n,&s,&en))
{
if(not_first)
printf("\n");
not_first=true; len=0;
for(int i=1;i<=n;i++)
{
dis_s[i]=dis_r[i]=INF;
head[i]=path_r[i]=path_s[i]=-1;
} int m;
scanf("%d",&m);
for(int i=0;i<m;i++)
{
int from,to,val;
scanf("%d%d%d",&from,&to,&val);
add(from,to,val);
add(to,from,val);
}
dijkstra(s,dis_s,path_s);
dijkstra(en,dis_r,path_r); int k;
scanf("%d",&k);
int ans_from=-1,ans_to,ans_val,ans=dis_s[en]; for(int i=0;i<k;i++)
{
int from,to,val,temp;
scanf("%d%d%d",&from , &to , &val );
temp=dis_s[from] + dis_r[to] + val;
if(temp < ans)
{
ans=temp;
ans_from=from;
ans_to=to;
ans_val=val;
}
temp=dis_s[to] + dis_r[from] + val;
if(temp < ans)
{
ans=temp;
ans_from=to;
ans_to=from;
ans_val=val;
}
}
if(ans_from==-1)
print(en);
else
{
print(ans_from);
int cur=ans_to;
while(cur!=en)
{
printf("%d ",cur);
cur=path_r[cur];
}
printf("%d\n",en);
}
if(ans_from==-1)
printf("Ticket Not Used\n");
else
printf("%d\n",ans_from);
printf("%d\n",ans); } return 0;
}

采用SLF优化的SPFA版本:0.015s

#include<cstdio>
#include<cstring>
#include<queue>
const int INF=999999;
const int MAXN=520;
const int MAXM=2520;
using namespace std;
struct edge
{
int to;
int val;
int next;
}e[MAXM]; int head[MAXN],len;
int dis_s[MAXN],dis_r[MAXN],path_s[MAXN],path_r[MAXN]; void add(int from,int to,int val)
{
e[len].to=to;
e[len].val=val;
e[len].next=head[from];
head[from]=len++;
} int n,s,en;
void SPFA(int start,int dis[],int path[])
{
bool vis[MAXN]={0};
dis[start]=0; deque<int> q;
q.push_back(start);
vis[start]=true;
while(!q.empty())
{
int cur=q.front();
q.pop_front();
vis[cur]=false;
for(int i=head[cur];i!=-1;i=e[i].next)
{
int id=e[i].to;
if( dis[cur] + e[i].val < dis[id] )
{
path[id]=cur;
dis[id]=dis[cur] + e[i].val;
if(!vis[id])
{
if(!q.empty() && dis[id] <dis[q.front()] )
q.push_front(id);
else
q.push_back(id);
vis[id]=true;
}
}
}
}
}
void print(int cur)
{
if(path_s[cur]!=-1)
print(path_s[cur]); if(cur!=en)
printf("%d ",cur);
else
printf("%d\n",cur);
}
int main()
{
bool not_first=false;
while(~scanf("%d%d%d",&n,&s,&en))
{
if(not_first)
printf("\n");
not_first=true; len=0;
for(int i=1;i<=n;i++)
{
dis_s[i]=dis_r[i]=INF;
head[i]=path_r[i]=path_s[i]=-1;
} int m;
scanf("%d",&m);
for(int i=0;i<m;i++)
{
int from,to,val;
scanf("%d%d%d",&from,&to,&val);
add(from,to,val);
add(to,from,val);
}
SPFA(s,dis_s,path_s);
SPFA(en,dis_r,path_r); int k;
scanf("%d",&k);
int ans_from=-1,ans_to,ans_val,ans=dis_s[en]; for(int i=0;i<k;i++)
{
int from,to,val,temp;
scanf("%d%d%d",&from , &to , &val );
temp=dis_s[from] + dis_r[to] + val;
if(temp < ans)
{
ans=temp;
ans_from=from;
ans_to=to;
ans_val=val;
}
temp=dis_s[to] + dis_r[from] + val;
if(temp < ans)
{
ans=temp;
ans_from=to;
ans_to=from;
ans_val=val;
}
}
if(ans_from==-1)
print(en);
else
{
print(ans_from);
int cur=ans_to;
while(cur!=en)
{
printf("%d ",cur);
cur=path_r[cur];
}
printf("%d\n",en);
}
if(ans_from==-1)
printf("Ticket Not Used\n");
else
printf("%d\n",ans_from);
printf("%d\n",ans); } return 0;
}

最新文章

  1. Web Essentials之Bundling
  2. SVN代码回滚
  3. Android 使用Telephony API
  4. RequireJS进阶(一) 转
  5. jquery的相对父元素和相对文档定位示例代码
  6. Qt 学习之路:视图选择 (QItemSelectionModel)
  7. python循环,判断及函数
  8. sqlserver 分页查询总结
  9. [c++]大数运算1---利用C++ string实现任意长度正小数、整数之间的加减法
  10. JAVA基础-反射
  11. 微信小程序开发过程问题总汇
  12. HihoCoder - 1103 Colorful Lecture Note
  13. Python初级面试语法&lt;一&gt;
  14. Flask 系列之 SQLAlchemy
  15. MonkeyRunner测试工具小结
  16. 关于mysql远程连接
  17. hive grouping sets 实现原理
  18. WEB框架Django之Form组件
  19. 常用到的一些js方法,记录一下
  20. Hibernate学习(2):添加demo

热门文章

  1. Thinkphp的 is null 查询条件是什么,以及exp表达式如何使用
  2. 4.Maven之(四)Maven命令
  3. Vue的响应原理
  4. Impala储存与分区
  5. C++标准库概述
  6. 分享一下事件监听addEventListener----attachEvent的用法
  7. ajax的使用(一)
  8. 如何优雅的写UI——(6)内存泄漏
  9. apache 使用 mod_fcgid.so模块时 配置指令
  10. highcharts 阶梯图表并填充颜色(自己觉得:直角折线图表)