Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3 
描述:Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For             example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit 
输入:The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10,           and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出:For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011
样例输出
3
0
3
#include<iostream>//我用模式匹配算子串出现的次数
#include<string>
using namespace std; int Match(string pat,string sat)
{
int count=;
int i=;
int m=pat.length(),n=sat.length();
while(i<=(n-m))
{
int j=;
while((sat[i]==pat[j])&&(j<pat.length()))
{
i++;
j++; }
if(j==pat.length())
{
count++;
}
i=i-j+;
} return count;
}
int main()
{ int num;
cin>>num;
string pat,sat;
while(num--)
{
int p=,s=;
int count;
cin>>pat;
cin>>sat; count=Match(pat,sat);
cout<<count<<endl;
} return ;
}

最新文章

  1. 分享几个原生javascript面向对象设计小游戏
  2. Robotium自动化测试框架实用教程(图)
  3. PHP单引号和双引号的区别
  4. MongoDB的find用法
  5. [转]C#综合揭秘——细说进程、应用程序域与上下文之间的关系
  6. OK - A byte of python - 读书笔记
  7. [转]python下很帅气的爬虫包 - Beautiful Soup 示例
  8. mac下面xcode+ndk7配置cocos2dx &amp; box2d的跨ios和android平台的游戏教程
  9. UVA 10340 (13.08.25)
  10. PHP图片等比缩放,并添加Logo水印特定代码和盯
  11. flex与后台及页面间对象的传递
  12. 网页 cookie
  13. StructureMap经典的IoC/DI容器
  14. @Controller和@RestController之间的区别
  15. 【玩转开源】BananaPi R2 —— 第一篇 Openwrt安装
  16. WEB前端 HTML
  17. strace常用参数详解
  18. tensorflowwindows安装
  19. 【Windows】XShell中使用小键盘和ALT键(作Meta键),使BackSpace正常
  20. 【Python爬虫】教务处模拟登陆

热门文章

  1. js可以控制文件上传的速度吗?
  2. centos安装python的虚拟环境和虚拟管理环境
  3. springboot mybatis 项目框架源码 shiro 集成代码生成器 ehcache缓存
  4. react 使用 moment 进行 日期格式化
  5. Expression Tree 学习笔记(一)
  6. eureka高可用注册中心
  7. top load average
  8. MySQL安装、安装时未提示输入密码、如何修改密码小结
  9. mysql优化---in型子查询,exists子查询,from 型子查询
  10. 关于animate的一些属性