题目链接:

pid=2669">http://acm.hdu.edu.cn/showproblem.php?pid=2669

Problem Description
The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You. 

................................Write in English class by yifenfei



 



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 
Input
The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)
 
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 
Sample Input
77 51
10 44
34 79
 
Sample Output
2 -3
sorry
7 -3
 
Author
yifenfei
 
Source

PS:

扩展欧几里德模板题。

附:扩展欧几里德解说:http://blog.csdn.net/u012860063/article/details/39760003

代码例如以下:

#include <cstdio>
#include <cstring>
#include <cmath>
typedef __int64 LL; LL exgcd(LL a,LL b,LL &x,LL &y)
{
if(b == 0)
{
x = 1;
y = 0;
return a;
}
LL r = exgcd(b,a%b,x,y);
LL t = x;
x = y;
y = t-a/b*y;
return r;
} int main()
{
LL a,b,x,y;
while(scanf("%I64d%I64d",&a,&b)!=EOF)
{
LL d = exgcd(a,b,x,y);
if(1%d)//不能整除
printf("sorry\n");
else
{
while(x<0)
x+=b,y-=a;
printf("%I64d %I64d\n",x,y);
}
}
return 0;
}

最新文章

  1. 云与备份之(1):VMware虚机备份和恢复
  2. spring框架详解: IOC装配Bean
  3. 【转载】MySQL启多个实例
  4. log4j2 使用说明
  5. 管理员 修改MySQL 5.7.9 新版本的root密码方法以及一些新变化整理
  6. TCP头分析+面试题
  7. 欧拉函数K - Relatives
  8. Friends
  9. python--网络编程requests
  10. http/https协议
  11. Codeforces831B Keyboard Layouts
  12. HashMap 和 Hashtable 的 6 个区别,最后一个没几个人知道!
  13. TeamLab安装及使用
  14. tesorflow - create neural network+结果可视化+加速神经网络训练+Optimizer+TensorFlow
  15. sql的with as用法
  16. Servlet 会话技术cookie和session
  17. JS 使用html2canvas实现页面截图功能
  18. linux上安装python2.7.11
  19. android studio开发的时候出现design editor is unavailable until after a successful project sync问题的解决方法
  20. linux java环境变量设置

热门文章

  1. python基础学习笔记——包
  2. 【Luogu】P1972HH的项链(链表+树状数组)
  3. jsp 详解request对象
  4. 等价表达式(codevs 1107 答案错误)
  5. Lucene 6.5.0 入门Demo(2)
  6. golang-random随机数
  7. 装B技能GET起来!Apple Pay你会用了吗?
  8. AC日记——L国的战斗之间谍 洛谷 P1916
  9. ubuntu 命令行模式和图形界面切换
  10. 关于Properties 集 添加数据 遍历数据