Beauty Contest
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 31414   Accepted: 9749

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their
cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 



Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills
her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 


Input

* Line 1: A single integer, N 



* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

题意是给了二维坐标下的点,问在这些点中最远的两个点 距离的平方。

最远的两个点一定在凸包上,所以先找凸包上的点,在对凸包上的点求其距离平方找最大值。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; int n; struct no
{
int x, y;
}node[50005]; int conbag[50005];
no orign;//原点 int dis(no n1, no n2)
{
return (n1.x - n2.x)*(n1.x - n2.x) + (n1.y - n2.y)*(n1.y - n2.y);
} int xmult(int x1, int y1, int x2, int y2)
{
return x1*y2 - x2*y1;
} int Across(no n1, no n2, no n3, no n4)
{
return xmult(n2.x - n1.x, n2.y - n1.y, n4.x - n3.x, n4.y - n3.y);
} int cmp(const void* n1, const void* n2)//qsort和我原来想象的是完全相反的。。。
{
int temp = Across(orign, *(no *)n1, orign, *(no *)n2); if (temp > 0)
{
return -1;
}
else if (temp == 0)
{
return (dis(orign, *(no *)n1) - dis(orign, *(no *)n2));
}
else
{
return 1;
}
} int main()
{
int i, j, min_x, pos_x;
while (cin >> n)
{
min_x = 10005;
pos_x = 0; for (i = 1; i <= n; i++)
{
cin >> node[i].x >> node[i].y; if (node[i].x < min_x)
{
min_x = node[i].x;
pos_x = i;
}
else if (min_x == node[i].x&&node[i].y < node[pos_x].y)
{
pos_x = i;
}
}
orign = node[pos_x];
qsort(node + 1, n, sizeof(no), cmp); int pc = 1;
conbag[1] = 1;
conbag[++pc] = 2;
conbag[0] = 2; i = 3;
while (i <= n)
{
if (Across(node[conbag[pc - 1]], node[conbag[pc]], node[conbag[pc]], node[i]) >= 0)
{
conbag[++pc] = i++;
conbag[0]++;
}
else
{
pc--;
conbag[0]--;
}
}
int max_n = 0;
for (i = 1; i <= conbag[0]; i++)
{
for (j = i + 1; j <= conbag[0]; j++)
{
max_n = max(dis(node[conbag[i]], node[conbag[j]]), max_n);
}
}
cout << max_n << endl;
} return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. Spring配置文件标签报错:The prefix &quot;XXX&quot; for element &quot;XXX:XXX&quot; is not bound. .
  2. 【译】Meteor 新手教程:在排行榜上添加新特性
  3. 重装系统后,delphi7打开报错
  4. 简单又高效的Access分页语句
  5. BestCoder27 1002.Taking Bus(hdu 5163) 解题报告
  6. 《C#本质论》读书笔记(14)支持标准查询操作符的集合接口
  7. redis Transaction支持
  8. MassTransit_契约的创建
  9. 套题T3
  10. compile libvirt
  11. Alice&amp;#39;s Chance
  12. Linux并发模型
  13. 利用GDI+在Winfrom绘制验证码
  14. C4 垃圾回收
  15. Linux运维小知识
  16. linux 压缩文件或文件夹
  17. 【Quartz】问题记录注意事项【四】
  18. java导出excel时合并同一列中相同内容的行
  19. ffmpeg在asp.net 视频转换
  20. 高并发 Web 服务的演变:节约系统内存和 CPU

热门文章

  1. u盘装完centos系统恢复
  2. 「NOIP2011」Mayan游戏
  3. Django 数据库访问性能优化
  4. Java 推荐读物与源代码阅读
  5. 在Ubuntu下如何压缩一个文件夹
  6. jmeter用Stepping Thread Group 递增并发数
  7. 51nod 1416:两点 深搜
  8. 当3D打影人头”成为黑客的秘密武器,隐私该如何保护?
  9. iOS中html打开APP传参
  10. 微信小程序-发送模板消息