1037. Magic Coupon (25)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

。。。。。。。。。。。。。。。。我的代码的也很乱

#include"iostream"
#include "algorithm"
#include "string"
#include "vector"
using namespace std;
#define max 100001

int nc[max],np[max];
bool mycompare(int a, int b)
{
return a>b;
}
int main()
{
int c,p,sum=0;
cin >> c;
for(int i=0;i<c;i++)
cin >> nc[i];
sort(nc,nc+c,mycompare);
cin >> p;
for(int i=0;i<p;i++)
cin >> np[i];
sort(np,np+p,mycompare);
int min = c<p? c:p;
int mx = c>p? c:p;
if(mx == min)
{
for(int i=0;i<min;i++)
if(nc[i]*np[i]>=0)
sum +=np[i]*nc[i];
if(sum==0)
sum=np[0]*nc[min-1]>np[min-1]*nc[0]?np[0]*nc[min-1]:np[min-1]*nc[0];//考虑 两个数组符号全部不相同时就去一个数最小的数
}
else
{
if(c==min)
{
for(int i=0;i<c;i++)
{
if(nc[i]*np[i]>=0)
sum +=nc[i]*np[i];
}
if(sum==0)
sum =np[0]*nc[min-1]>np[mx-1]*nc[0]?np[0]*nc[min-1]:np[mx-1]*nc[0];

}

else if(c==mx)
{
for(int i=0;i<p;i++)
{
if(nc[i]*np[i]>=0)
sum +=nc[i]*np[i];
}
if(sum==0)
sum =np[0]*nc[mx-1]>np[min-1]*nc[0]?np[0]*nc[mx-1]:np[min-1]*nc[0];

}
}
cout << sum <<endl;
return 0;
}

最新文章

  1. C++ std::queue
  2. DICOM图像像素值(灰度值)转换为CT值
  3. 完美C++(第5版)(双色)
  4. 炮兵阵地 POJ 1185
  5. js随机生成N位数
  6. [Leetcode][JAVA] Pascal&#39;s Triangle I, II
  7. Dynamic CRM 2013学习笔记(二十三)CRM JS智能提示(CRM 相关的方法、属性以及页面字段),及发布前调试
  8. C#三种模拟自动登录和提交POST信息的实现方法
  9. OC——类
  10. ruby中输入命令行编译sass(ruby小白)
  11. HTK语音识别示例(Ubuntu)
  12. USB OTG简介、与普通USB线的区别
  13. TP5 模型类和Db类的使用区别
  14. [BZOJ]1031 字符加密Cipher(JSOI2007)
  15. 成员函数的const到底修饰的是谁
  16. python中的GIL详解
  17. (四)JavaScript 注释
  18. python动态构建类(类似声明)
  19. MUI 选项卡切换+下拉刷新动态 完整实现一例
  20. 20155320 2016-2017-2《Java程序设计》第八周学习总结

热门文章

  1. Mac + nginx + lua + luasocket + cjson
  2. noip 2016 提高组题解
  3. gulp 安装步骤
  4. 洛谷-拼数-NOIP1998提高组复赛
  5. C#+ArcEngine中com对象的释放问题
  6. 设置ios中imageView图片自适应,
  7. jqery总结
  8. EM算法及其推广的要点
  9. 父子页面(iframe)相互获取对方dom元素
  10. vs2013 中已经添加了引用,编译还是提示没有添加引用