BST
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9140   Accepted: 5580

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and
we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

发现每个点含有的节点数量就是做树状数组时lowbit()的值,lowbit()就是一个数x在二进制表示下最右边的那个1保留,其余值全部赋值为0的二进制数。

简单表示就是x&(x^(x-1))=x&(-x)。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std; const int N = 32005; int c[N],a[N],n; int lowbit(int x)
{
return x & (-x);
} int main()
{
int i,query;
long long ask;
scanf("%d",&query); for(i=1;i<=query;i++)
{
cin>>ask;
cout<<ask-(lowbit(ask)-1)<<" "<<ask+(lowbit(ask)-1)<<endl;
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. Swift #function 和 _cmd (Objective-C)
  2. 深入理解使用ListView时ArrayAdapter、SimpleAdapter、BaseAdapter的原理
  3. js的异步执行
  4. Zabbix3.0 自动邮件报障
  5. Manacher算法 - 求最长回文串的利器
  6. 转:C/C++中,空数组、空类、类中空数组的解析及其作用
  7. Firefly官方教程之Distributed使用文档
  8. Pet
  9. csv和excel的区别
  10. Word常用实用知识2
  11. loadrunner学习理论之一
  12. [hihoCoder]矩形判断
  13. BZOJ_1823_[JSOI2010]满汉全席_2-sat+tarjan
  14. centos 7 aufs
  15. Appium学习——安装appium Server
  16. 如何启动Intel VT-X及合理利用搜索
  17. (转)yuicompressor 与 maven结合,打包,压缩js,css (一)
  18. C#读取Excel表格的数据
  19. [Backbone]2. More detail in Models
  20. javascript 实现 A-star 寻路算法

热门文章

  1. FTP的vsftpd.conf含义
  2. PHP中的异常知识
  3. java并发AtomicIntegerArray
  4. 配置solrcloud
  5. redis-Hash(哈希表)
  6. CMake查找第三方库路径
  7. vue通过路由传值及在页面刷新后如何保存值
  8. Python数据分析在互联网寒冬下,数据分析师还吃香吗?
  9. 创建Git本地仓库
  10. SciPy 介绍