CF546B Soldier and Badges

题意翻译

给 n 个数,每次操作可以将一个数 +1,要使这 n 个数都不相同, 求最少要加多少? \(1 \le n \le 3000\)

感谢@凉凉 提供的翻译

题目描述

Colonel has \(n\) badges. He wants to give one badge to every of his \(n\) soldiers. Each badge has a coolness factor, which shows how much it's owner reached. Coolness factor can be increased by one for the cost of one coin.

For every pair of soldiers one of them should get a badge with strictly higher factor than the second one. Exact values of their factors aren't important, they just need to have distinct factors.

Colonel knows, which soldier is supposed to get which badge initially, but there is a problem. Some of badges may have the same factor of coolness. Help him and calculate how much money has to be paid for making all badges have different factors of coolness.

输入格式:

First line of input consists of one integer \(n\) ( \(1 \le n \le 3000,1 \le n \le 3000\) ).

Next line consists of \(n\) integers \(a_{i}\) ( \(1 \le a_{i} \le n\) ), which stand for coolness factor of each badge.

输出格式:

Output single integer — minimum amount of coins the colonel has to pay.

输入输出样例

输入样例#1:

4
1 3 1 4

输出样例#1:

1

输入样例#2:

5
1 2 3 2 5

输出样例#2:

2

说明

In first sample test we can increase factor of first badge by \(1\) .

In second sample test we can increase factors of the second and the third badge by \(1\) .


思路

其实这道题的思想很简单,就是每次遇到一个没有出现过的的数,就把之前的一个重复的数变成这个数。。。

我的代码可能有点奇怪。。。

我的主要思想是把取到的数的和 - 原来的和,然后就是答案。

具体看代码吧——

代码

#include<cstdio>
#include<queue>
using namespace std;
#define MAXN 3005 int n, ans, t, s;
int nn;
int a[MAXN * 2]; int main(){
scanf( "%d", &n );
for ( int i = 1; i <= n; ++i ) scanf( "%d", &t ), a[t]++, s += t, nn = max( nn, t );//哈希计数
t = 0;
for ( int i = 1; i <= 6000; ++i ){
if ( t == 0 && i > nn ) break;
if ( t > 0 && a[i] == 0 ) t--, ans += i;//把一个该改的数改成这个数
if ( a[i] > 1 ) t += a[i] - 1;//又多了这么多个待改变的数
if ( a[i] ) ans += i;//不改变的话也要加哦
}
printf( "%d\n", ans - s );
return 0;
}

最新文章

  1. C语言创建及解析Json的使用法则
  2. Newtonsoft.json中 linq to json 和序列化哪个快?
  3. 学习3ds max插件开发过程中的一些小结
  4. CSS3与页面布局学习笔记(二)——盒子模型(Box Model)、边距折叠、内联与块标签、CSSReset
  5. factory工厂模式之工厂方法FactoryMethod
  6. 17.1.1.3 Creating a User for Replication 创建一个用于用于复制:
  7. (Problem 19)Counting Sundays
  8. input text中不能显示空格后的内容
  9. mac使用小提示
  10. 字符串转义为HTML
  11. weblogic中部署项目通常有三种方式
  12. UGUI学习——Canvas基础组件
  13. android面试题总结加强再加强版(一)
  14. cestOs 7安装Jenkins
  15. StanFord ML 笔记 第九部分
  16. python 皮尔森相关系数
  17. Java基础知识强化之集合框架笔记79:HashMap的实现原理
  18. Ubuntu下安装Nginx详细步骤
  19. Java多线程学习(三)volatile关键字
  20. PIE SDK导出图片

热门文章

  1. 「HNOI2015」菜肴制作
  2. yeoman&amp;bower
  3. Python--day67--CBV和FBV、Request对象及上传文件示例
  4. 智课雅思词汇---九、mon是什么意思
  5. clone() 方法
  6. 评分模型的检验方法和标准通常有:K-S指标、交换曲线、AR值、Gini数等。例如,K-S指标是用来衡量验证结果是否优于期望值,具体标准为:如果K-S大于40%,模型具有较好的预测功能,发展的模型具有成功的应用价值。K-S值越大,表示评分模型能够将“好客户”、“坏客户”区分开来的程度越大。
  7. PHP 面试题三
  8. Vue中computed与method的区别
  9. Flex AIR应用的启动闪屏(必须)
  10. poj 2996