Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15604   Accepted: 3976

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at
a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount
of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount
of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5 sample input #2
3
2 3 6
5

Sample Output

sample output #1
3 sample output #2
2

Source

Northeastern Europe 2005, Northern Subregion



————————————————————————————————————
题目的意思是给出n条衣服,每条衣服带水ai,单位时间每条会自然风干减少1单位水,有一台烘干机,单位时间可以帮助减少k单位水(不属于自然风干了),求全部弄干需要多少时间
思路:二分+验证 二分时间,算出能否在该时间烘干,设当前为x,每件衣服应该自然减少x单位,烘干机可视为减少(k-1)单位,然后去检查能否完成
注意:k可能等于1,可能会出现/0RE情况 特判即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long LL a[100005],k;
int n; bool ok(LL x)
{
LL ans=0;
for(int i=0; i<n; i++)
{
LL xx=max((LL)0,a[i]-x);
ans=ans+(xx+k-1)/k;
}
if(ans<=x)
return 1;
return 0;
} int main()
{
while(~scanf("%d",&n))
{
for(int i=0; i<n; i++)
{
scanf("%lld",&a[i]);
}
scanf("%lld",&k);
if(k==1)
{
LL ans =-1;
for(int i=0; i<n; i++)
ans=max(ans,a[i]);
printf("%lld\n",ans);
}
else
{
k--;
LL l=0,r=1e9;
LL ans=-1;
while(l<=r)
{
LL mid=(l+r)/2;
if(ok(mid))
{
r=mid-1;
ans=mid;
}
else
l=mid+1;
}
printf("%lld\n",ans);
}
} return 0;
}

最新文章

  1. PHP7函数大全(4553个函数)
  2. 【Windows编程】系列第十篇:文本插入符
  3. Spring配置文件中别名的使用
  4. python 常用高效代码写法集锦
  5. this及其作用域(函数外部this变量的调用)
  6. error C2065:未声明的标识符错误
  7. linux下跨服务器文件文件夹的复制
  8. 使用EF 的简单的增删改查
  9. (转)java 23种设计模式
  10. 表单javascript checkbox全选 反选 全不选
  11. python--data type
  12. Mongodb 集群搭建以及常见错误(不分块,分片,以及加验证)
  13. 二十七、oracle 例外
  14. ext遍历表单中所有输入项,并全部设置为只读
  15. emmet前端模板
  16. 《Python》网络编程之黏包
  17. 12.13java过关测试
  18. D3.js的基础部分之选择集的处理 enter和exit的处理方法 (v3版本)
  19. 在浏览器输入网址,Enter之后发生了什么?
  20. 解决pymysql.err.InternalError: (1366, &quot;Incorrect string value: &#39;\\xF0\\x9F\\x8C\\xB8&#39; for column &#39;headline&#39; at row 1&quot;)

热门文章

  1. 【Java】JVM(一)、Java内存区域
  2. php的websocket
  3. ReactNative手势解锁(react-native-ok-gesture-password)
  4. java并发:AtomicInteger 以及CAS无锁算法【转载】
  5. 第六章&#160;图(c)广度优先搜索
  6. linux系统分区表修复
  7. haproxy 参数说明
  8. ECMAScript3的原型
  9. 两台Linux之间传文件
  10. Swift 项目中可能用到的第三方框架