题目链接

Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8 Hint
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

分析:

题目说的是一个分糖果的游戏,n个学生围成一圈,每个人手上有a[i]个糖果,每一轮游戏开始时,学生手中的糖果都是偶数,他们都把自己手中一半的糖果分给他右边的同学。分完后手中糖果数是奇数的,老师会给他一颗糖果。如果所有人手中的糖果数都一样 游戏结束。

输出总共进行了多少轮游戏 还有最后学生手中的糖果数。

数组模拟整个游戏的过程即可。

代码:

#include<stdio.h>
int main()
{
int N,i,a[1000];
while(~scanf("%d",&N)&&N)
{
for(i=1; i<=N; i++)
scanf("%d",&a[i]);
int op=0;
while(1)
{
for(i=1; i<N; i++)
if(a[i]!=a[i+1])
break;
if(i>=N)
break;
op++;
int m=a[N]/2;
for(i=N; i>1; i--)
{
a[i]=a[i]/2;
a[i]=a[i]+a[i-1]/2;
}
a[1]=a[1]/2;
a[1]=a[1]+m;
for(i=1; i<=N; i++)
if(a[i]%2==1)
a[i]++;
}
printf("%d %d\n",op,a[1]);
}
return 0;
}

最新文章

  1. 奥迪--A3
  2. bash命令行返回值和展开
  3. 一次偶然的Java内存溢出引发的思考
  4. (旧)子数涵数&#183;DW——图文混排页面
  5. Qt与VC编程合作起龌龊
  6. 【GDI+】 线段 文字 定位的问题(二)
  7. CentOS 6.4 U盘启动问题的解决
  8. delphi 调用 webservice (.NET C#版)
  9. 关于php程序员 解决问题的能力
  10. 记JavaScript的入门学习(二)
  11. iOS底层学习-KVC使用实践以及实现原理
  12. 甲方VS乙方
  13. lodash源码分析之获取数据类型
  14. hadoop 部署和调优
  15. LinkedHashMap和TreeMap的有序性
  16. 解决 main(int argc, char** argv)这种情况下通过命令行传参,改为main函数里面给定参数。
  17. 翻译1-在SQL Server 2016中介绍微软R服务
  18. rancher中使用ingress-lbs做负载均衡
  19. Laravel 完整开源项目大全
  20. C++MFC之picture control控件铺满图片

热门文章

  1. psp 第二周
  2. python/django将mysql查询结果转换为字典组
  3. 【loj6041】「雅礼集训 2017 Day7」事情的相似度 后缀自动机+STL-set+启发式合并+离线+扫描线+树状数组
  4. [四]SpringBoot 之 捕捉全局异常
  5. BZOJ4921 互质序列
  6. 【BZOJ2109/2535】【NOI2010】航空管制(贪心)
  7. 同时装了Python3和Python2,怎么用pip?
  8. spring集成webSocket实现服务端向前端推送消息
  9. The 14th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple - F 贪心+二分
  10. Codeforces Round #358 (Div. 2) A B C 水 水 dfs序+dp