A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball’s moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag’s current value at this node is false, then the ball will first switch this flag’s value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag’s value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

  For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag’s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag’s values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag’s values at node 1, node 2, and node 5 before it stops at

position 10.

  Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

  Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the I-th ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT. Please write a program to determine the stop position P for each test case.

  For each test cases the range of two parameters D and I is as below:

2≤ D ≤20, and 1≤ I ≤524288.

Input

Contains l +2 lines.

Line 1 l the number of test cases

Line 2 D1 I1 test case #1, two decimal numbers that are separated by one blank

...

Line k +1 Dk Ik test case #k Line l +1 Dl Il test case #l

Line l +2 -1 a constant ‘-1’ representing the end of the input file

Output

Contains l lines.

Line 1 the stop position P for the test case #1

...

Line k the stop position P for the test case #k

...

Line l the stop position P for the test case #l

Sample Input

5
4 2
3 4
10 1
2 2
8 128
-1

Sample Output

12
7
512
3
255

HINT

这个题目最重要的是他的结论:

  1. 给定一棵包含2 d 个结点(其中d 为树的高度)的完全二叉树,如果把结点从上到下从左到右编号为1,2,3……,则结点k 的左右子结点编号分别为2k 和2k +1。
  2. 如果使用题目中给出的编号I ,则当I 是奇数时,它是往左走的第(I +1)/2个小球;当I 是偶数时,它是往右走的第I /2个小球。

Accepted

#include <bits/stdc++.h>
using namespace std;
int main()
{
int s, m, n;
while (cin >> s&&s!=-1) {
while (s--){
cin >> m >> n;
unsigned long long int k = 1;
for (int i = 0;i < m - 1;i++)
if (n % 2) { k = k * 2;n = (n + 1) / 2; }
else { k = k * 2 + 1;n /= 2; }
cout<<k<<endl;
}
}
}

最新文章

  1. ABP源码分析三十二:ABP.SignalR
  2. 为jQuery添加Webkit的触摸方法支持
  3. WebStorm文件类型关联设置
  4. python实现计算器
  5. Android WebView 保存cache至External Storage
  6. js实现网页瀑布流布局
  7. LeetCode:Permutations(求全排列)
  8. ZooKeeper实践方案:(7) 分布式锁
  9. pytorch预训练
  10. 启动tomcat时报错:http-nio-8080-exec-10
  11. Vue2+VueRouter2+webpack 构建项目实战(五):配置子路由
  12. python3写入csv文件时中文为乱码
  13. Linux 安全信息查看
  14. 如何获取某个网站的favicon.ico
  15. 工具WinSCP:windows和Linux中进行文件传输
  16. MathType如何编辑手写体l
  17. pairs 和 ipairs异同
  18. Rest架构下的增删改查
  19. sqlite3日期数据类型
  20. Spark的操作列表

热门文章

  1. 三种远程部署war包检测
  2. JDBC概念理解
  3. mysql主从备份说明(win系统)
  4. 如何把数据放到C#的心里之 DB2实例
  5. 使用EF的Code First模式创建模型
  6. Git 命令将电脑上的文件上传到 Github
  7. Python3.x 基础练习题100例(21-30)
  8. 剑指 Offer 62. 圆圈中最后剩下的数字 + 约瑟夫环问题
  9. 如何在 C# 中使用 const,readonly,static
  10. 番外----python入门----pip相关