PAT甲级:1124 Raffle for Weibo Followers (20分)

题干

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

思路

  1. 需要输出keep going… 的时候,一定是起始点没有在范围里,只需判断一下起始点的位置特判输出它。
  2. 接下来就直接按照题意进行编写。比较简单。

code

#include <iostream>
#include <string>
#include <vector>
#include <unordered_map>
using namespace std;
int main(){
int n_user = 0, step = 0, index = 0;
scanf("%d%d%d", &n_user, &step, &index);
vector<string> list(n_user);
unordered_map<string, bool> dic;
for(int i = 0; i < n_user; i++){
list[i].resize(25);
scanf("%s", &list[i][0]);
}
if(index - 1 >= list.size()){
printf("Keep going...");
return 0;
}
for(int i = index - 1; i < list.size(); ){
if(!dic[list[i]]){
dic[list[i]] = true;
printf("%s\n", list[i].c_str());
i += step;
}else i++;
}
return 0;
}

最新文章

  1. java前后台之间传值的几种方式
  2. http协议详解&lt;一&gt;
  3. 在Unity中高效工作(上)
  4. #ifndef#define#endif的用法-b
  5. 如何监听input的脚本赋值
  6. VS快捷键教程
  7. 【实验室笔记】zedgraph控件属性总结
  8. CodeSmith系列(三)——使用CodeSmith生成ASP.NET页面
  9. Unity黑巧克力 滚球游戏 入门级教程
  10. HALCON学习-下载、安装
  11. centos7安装mongodb3.4
  12. HTTP长连接和短连接 + Websocket
  13. vs2017开发IOS(vs2017 xamarin 连接mac)
  14. zabbix3.2监控rabbitmq集群
  15. 学以致用三十三-----django生命周期
  16. Java 使用 int 数据计算百分比
  17. a标签的4种状态及设置CSS
  18. 数独_erlang解题代码
  19. 监督学习Supervised Learning
  20. hadoop本地集群搭建

热门文章

  1. 『无为则无心』Python基础 — 2、编译型语言和解释型语言的区别
  2. JAVA并行程序基础一
  3. 备份schema并排除大表到ASM磁盘上
  4. Java8-四个函数式接口(Consumer,Supplier,Predicate,Function)
  5. Centos7安装配置jenkins(Tomcat)
  6. 『无为则无心』Python基础 — 14、Python流程控制语句(while循环语句)
  7. 服务器硬件及RAID配置实战
  8. Redisson 分布式锁源码 01:可重入锁加锁
  9. Java高质量面试总结
  10. HDU 4292 Food 多源多汇入门题