有n个农场,编号1~N,农场里奶牛将去X号农场。这N个农场之间有M条单向路(注意),通过第i条路将需要花费Ti单位时间。选择最短时间的最优路径来回一趟,花费在去的路上和返回农场的这些最优路径的最长时间是多少?
思路:计算出每头牛去X并且回来的最短路径所需要的时间,然后求出这n-1个农场的牛的最长时间即可,两次运用dijkstra;
1 计算回来的时间:以X为源点,求出源点到各个农场的最短路径;
2 计算去的时间:将路径反转,在用一次djk,求源点到农场的最短路径(实则求牛去X的最短路径);
3 取两次和求最大值;

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int n,m,x,minn,k,ans=0;
int dp[1005][1005];
int dis[1005],vis[1005],dis2[1005];
const int inf=99999999;
/*dijkstrak算法*/
void djk(int x)
{
for(int i=1;i<=n;i++)
vis[i]=0;
vis[x]=1;
for(int i=1;i<=n;i++)//记录点i到x的距离
dis[i]=dp[x][i];
for(int i=1;i<=n;i++)
{
minn=inf;
for(int j=1;j<=n;j++)//两个农场之间取最短的路径
{
if(!vis[j]&&dis[j]<minn)
{
minn=dis[j];
k=j;
}
}
vis[k]=1;
for(int j=1;j<=n;j++)
{
if(!vis[j]&&dis[j]>dis[k]+dp[k][j])
dis[j]=dis[k]+dp[k][j];
}
}
}
int main()
{
while(scanf("%d %d %d",&n,&m,&x)!=EOF)//n头牛,m个例子,终点x;
{
for(int i=0;i<=n;i++)//这里i的范围要取小于n,如果取小于1005z则会runtime error
{//重置数组
for(int j=0;j<=n;j++)
  {
if(i==j)
dp[i][j]=0;//从i到i距离为0,else为inf;
   else
dp[i][j]=inf;
}
}
for(int i=0;i<m;i++)
{
int u,v,w;
scanf("%d %d %d",&u,&v,&w);
if(dp[u][v]>w)
dp[u][v]=w;
}
djk(x);
for(int i=1;i<=n;i++)
dis2[i]=dis[i];//记录distant函数之后的dis的数据 for(int i=1;i<=n;i++)//交换地图,路还是以前的路,只是起点和终点换了一下而已
{
for(int j=i+1;j<=n;j++)
{
int tem;
tem=dp[j][i];
dp[j][i]=dp[i][j];
dp[i][j]=tem;
}
}
djk(x);
for(int i=1;i<=n;i++)
{
ans=max(ans,dis2[i]+dis[i]);
}
printf("%d\n",ans);
}
}

最新文章

  1. Python的平凡之路(7)
  2. ajax请求成功后打开新窗口地址
  3. 编写测试类,了解ArrayList的方法
  4. iOS 开发者必不可少的 75 个工具,你都会了吗
  5. freemarker判断记录集是不是为空
  6. RabbitMQ安装简单过程
  7. jquery实现页面置顶功能代码
  8. 【C#学习笔记】二、面向对象编程
  9. 解决“您必须先更新GOOGLE play才能运行此应用”的问题
  10. BZOJ 1046: [HAOI2007]上升序列(LIS)
  11. Curator Recipes(Cache&amp;Counter)
  12. 完整的 HTML 4 + HTML 5 实体参考手册
  13. css3 图片阴影
  14. python之旅七【第七篇】面向对象之类成员
  15. Kafka Offset相关命令总结
  16. 《剑指offer》顺时针打印矩阵
  17. MYSQL 线程池
  18. JSONP原理及jQuery中的使用
  19. Java 多线程 破解密码 demo
  20. java学习之路之javaSE基础1

热门文章

  1. 《Spring Boot 实战纪实》之前言
  2. WPF时间长度自定义选择控件TimeSpanBox
  3. Mac安装mysqlclient
  4. 【JavaWeb】现代 JavaScript 教程
  5. 【JavaWeb】XML 文件
  6. 剑指offer 面试题0:扎实的基础:即编程语言、数据结构和算法
  7. os-hackos-3-docker提权
  8. 使用 gRPC-UI 调试.NET 5的gPRC服务
  9. Java 8中字符串拼接新姿势:StringJoiner
  10. ORB-SLAM2-tracking线程