题目

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

输入格式

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with two integers N and M, separated by a single space, with \(2 ≤ N ≤ 1,000\) and \(1 ≤ M ≤ 10, 000\): the number of cities and the number of roads in the road map.

M lines, each with three integers A, B and L, separated by single spaces, with \(1 ≤ A, B ≤ N, A ≠ B\) and \(1 ≤ L ≤ 1,000\), describing a road from city \(A\) to city \(B\) with length \(L\).

The roads are unidirectional. Hence, if there is a road from \(A\) to \(B\), then there is not necessarily also a road from \(B\) to \(A\). There may be different roads from a city A to a city B.

One line with two integers \(S\) and \(F\), separated by a single space, with \(1 ≤ S, F ≤ N\) and \(S ≠ F\): the starting city and the final city of the route.

There will be at least one route from \(S\) to \(F\).

输出格式

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

输入样例

2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

输出样例

3
2

代码

实际上就是最短路, 但是增加了一个次长路, 也很好解决

在Dijkstra更新时, 每次构建一个新路径, 做一下判断, 不仅更新最短路, 还要更新次短路

记录源点到某点的最短路和次短路

  1. 如果新路径小于最短路, 那么新路径变成最短路, 原来的最短路变成次短路;

  2. 如果新路径等于最短路, 那么最短路方法数+1

  3. 如果新路径大于最短路小于次短路, 更新次短路

  4. 如果新路径等于次短路, 那么次短路方法数+1

代码

#include <cstdio>
#include <cstring>
using namespace std;
const int INF = 0x3f3f3f3f, VM = 1010, EM = 10010;
struct Edge { int to, next, w; } edges[EM << 1];
int dis[VM][2], head[VM], num[VM][2], n, m, cnt;
bool vis[VM][2];
void add(int u, int v, int w) { edges[++cnt] = (Edge){v, head[u], w}, head[u] = cnt; }
void Dijkstra(int s, int e) {
memset(vis, false, sizeof(vis));
memset(num, 0, sizeof(num));
for (int i = 1; i <= n; i++) dis[i][0] = INF, dis[i][1] = INF;
dis[s][0] = 0, num[s][0] = 1;
int p, flag;
for (int i = 1; i <= 2 * n - 1; i++) {
int minn = INF;
for (int j = 1; j <= n; j++) {
if (!vis[j][0] && minn > dis[j][0]) {
flag = 0;
minn = dis[p = j][0];
} else if (!vis[j][1] && minn > dis[j][1]) {
flag = 1;
minn = dis[p = j][1];
}
}
if (minn == INF) break;
vis[p][flag] = true;
for (int j = head[p]; j; j = edges[j].next) {
int v = edges[j].to;
if (dis[v][0] > minn + edges[j].w) {
dis[v][1] = dis[v][0];
num[v][1] = num[v][0];
dis[v][0] = minn + edges[j].w;
num[v][0] = num[p][flag];
} else if (dis[v][0] == minn + edges[j].w)
num[v][0] += num[p][flag];
else if (dis[v][1] > minn + edges[j].w) {
dis[v][1] = minn + edges[j].w;
num[v][1] = num[p][flag];
} else if (dis[v][1] == minn + edges[j].w)
num[v][1] += num[p][flag];
}
}
if (dis[e][1] == dis[e][0] + 1) num[e][0] += num[e][1];
printf("%d\n", num[e][0]);
}
int main() {
int T;
scanf("%d", &T);
while (T--) {
cnt = 0;
memset(head, -1, sizeof(head));
scanf("%d%d", &n, &m);
int u, v, w;
while (m--) {
scanf("%d%d%d", &u, &v, &w);
add(u, v, w);
}
int s, e;
scanf("%d%d", &s, &e);
Dijkstra(s, e);
}
return 0;
}

最新文章

  1. swing中JTable的使用方法
  2. .Net(c#)模拟Http请求之HttpWebRequest封装
  3. lecture11-hopfiled网络与玻尔兹曼机
  4. 汉化入门之ExplorerControls
  5. [HDOJ5289]Assignment(RMQ,二分)
  6. java多线程为什么要用while而不是if
  7. java学习笔记_GUI(2)
  8. 使用mysql作为hive的元数据库
  9. jquery实现页面置顶功能代码
  10. linux下用gtk+写比赛赌博GUI小游戏
  11. mybatis第一次搭建出错
  12. python操作Redis安装、支持存储类型、普通连接、连接池
  13. 《JavaScript高级程序设计》笔记:引用类型(五)
  14. VUE开发请求本地数据的配置,旧版本dev-server.js,新版本webpack.dev.conf.js
  15. postMessage 实现跨源通信 iframe 跨域获取url
  16. Spring Framework框架容器核心源码逐步剖析
  17. java验证身份证合理性
  18. e671. 在缓冲图像中存取像素
  19. P03-Python装饰器
  20. subset II

热门文章

  1. apollo与springboot集成实现动态刷新配置
  2. Hive中row_number()、dense_rank()、rank()的区别
  3. JDK Base64编解码1.7和1.8的坑
  4. sublime安装ctags用于追踪函数
  5. Hunter’s Apprentice(判断所走路线为顺时针或逆时针)【Green公式】
  6. 机器学习中的标准化方法(Normalization Methods)
  7. Centos7 composer安装时 Warning: This development build of composer is over 60 days old. It is recommended to update it by running &quot;/usr/bin/composer self-update&quot; to get the latest version.
  8. webpack介绍—上
  9. S7-200 PLC内部+5VDC电源的负载能力
  10. RabbitMQ巩固学习一