It has been said that a watch that is stopped keeps better time than one that loses 1 second per day.
The one that is stopped reads the correct time twice a day while the one that loses 1 second per day
is correct only once every 43,200 days. This maxim applies to old fashioned 12-hour analog watches,
whose hands move continuously (most digital watches would display nothing at all if stopped).
Given two such analog watches, both synchronized to midnight, that keep time at a constant rate
but run slow by k and m seconds per day respectively, what time will the watches show when next they
have exactly the same time?
Input
Input consists of a number of lines, each with two distinct non-negative integers k and m between 0
and 256, indicating the number of seconds per day that each watch loses.
Output
For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute.
Valid times range from 01:00 to 12:59.
Sample Input
1 2
0 7
Sample Output
1 2 12:00
0 7 10:17

解题思路:

题意:

有两个表每天分别慢a,b秒,要求当这两个表重合的时候,A钟的时间;

思路:

首先要求两表重合,那么两表相差的时间必为12个小时: 43200/abs(a-b),求出所需的天数;

下一步则要求钟A此时走了多少秒  day*(86400-n); 因为这是表a记录的时间,所以要减去表a一天慢的秒数

最后就是时间的转换了;

实现代码:

#include<cstdio>
#include<cmath>
using namespace std;
#define ll long long
int main()
{
int a,b;
while(scanf("%d%d",&a,&b)!=EOF){
int ans = abs(a-b);
double day = 43200.0/ans;
ll tA = (ll)(day*(-a));
tA = tA%;
int min = tA/;
tA%=;
if(tA >= ) min++;
int hour = min/;
min %= ;
if(hour == )
hour = ;
printf("%d %d %02d:%02d\n", a,b, hour, min );
}
}

最新文章

  1. React Native FlexBox
  2. Node.js的循环与异步问题
  3. ue4 UE4Editor.lib找不到
  4. 如何保护在Autodesk应用程序商店的应用不被盗版 - 1
  5. CLR via C#(16)--泛型
  6. 论一次iOS面试
  7. eclipse中的Console控制台视图脱离主窗口解决办法
  8. IOS9新特性之Contacts联系人
  9. SpringBoot2.0 项目异常日志,但不影响运行(待解决)
  10. Building QGIS from source - step by step(随笔3)
  11. 查看crontab运行状态
  12. composer 常用操作
  13. 自定义实现HashMap的put、get方法
  14. 第三十二节,使用谷歌Object Detection API进行目标检测、训练新的模型(使用VOC 2012数据集)
  15. redis 一主二从三哨兵
  16. Java JDK5新特性-可变参数
  17. js里面进行位运算时候的注意事项
  18. 3.2 Multi-Master Replication
  19. Mosquitto----服务器日志
  20. C++分享笔记:扑克牌的洗牌发牌游戏设计

热门文章

  1. [05] 动态SQL
  2. ASP.NET Core 防止跨站请求伪造(XSRF/CSRF)攻击 (转载)
  3. Luogu2178 NOI2015 品酒大会 SA、并查集
  4. LiveCharts文档-3开始-6轴Axes
  5. Solr数据库导入
  6. BJOI2019 题解
  7. libmysqlclient.so.16: cannot open shared object file: No such file or directory
  8. 多校寒训TaoTao要吃鸡dp
  9. 【2016.3.18】作业 VS2015安装&amp;单元测试(2)
  10. Pair_Work Project