Air Raid
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6763   Accepted: 4034

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets
form no cycles. 



With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper
lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 



no_of_intersections 

no_of_streets 

S1 E1 

S2 E2 

...... 

Sno_of_streets Eno_of_streets 



The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets
in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk
<= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 



There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

Source

对于DAG,求最小路径覆盖有例如以下公式:最小路径覆盖数 = 节点数 - 相应的二分图最大匹配数。

用电脑自带的绘图画了张草图,挫爆了 -_-!


题意:输入数据具体解释,t组数据。n个节点(从1開始)。m条有向边。u到v。

题解:套公式。

#include <stdio.h>
#include <string.h> const int maxn = 125;
int n, m;
int cx[maxn], cy[maxn];
bool visy[maxn], G[maxn][maxn]; void getMap() {
memset(G, 0, sizeof(G));
int u, v;
scanf("%d%d", &n, &m);
while(m--) {
scanf("%d%d", &u, &v);
G[u][v] = true;
}
} int findPath(int x) {
int i;
for(i = 1; i <= n; ++i) {
if(G[x][i] && !visy[i]) {
visy[i] = 1;
if(cy[i] == -1 || findPath(cy[i])) {
cy[i] = x; return 1;
}
}
}
return 0;
} int MaxMatch() {
int ans = 0, i;
memset(cx, -1, sizeof(cx));
memset(cy, -1, sizeof(cy));
for(i = 1; i <= n; ++i) {
memset(visy, 0, sizeof(visy));
if(cx[i] == -1) ans += findPath(i);
}
return ans;
} void solve() {
printf("%d\n", n - MaxMatch());
} int main() {
// freopen("stdin.txt", "r", stdin);
int t;
scanf("%d", &t);
while(t--) {
getMap();
solve();
}
return 0;
}

最新文章

  1. Oracle 11g数据库详细安装步骤图解
  2. 使用matlab进行空间拟合
  3. 负载均衡的几种算法Java实现代码
  4. Eclipse定制右键创建文件快捷菜单
  5. Qt之qt4.7 和qt 4.8.4 交叉实践
  6. JSPatch中的OC高级语法
  7. PHP QR Code封装二维码生成教程
  8. C# WinForm多线程(三)Control.Invoke
  9. 基于Stm32的MP3播放器设计与实现
  10. 工作线程基类TaskSvc
  11. didMoveToSuperView 引发的思考
  12. TSQL语句和CRUD(20161016)
  13. 数据结构-栈(应用篇)之快速排序法-C和C++的实现
  14. VS2017 性能优化方法
  15. Go语言学习之3 流程控制、函数
  16. rectangle,boundingRect和Rect
  17. [转]Android中Intent传递对象的两种方法(Serializable,Parcelable)
  18. Linux下./configure &amp;&amp; make &amp;&amp; make install 编译安装和卸载
  19. css常用标签及属性
  20. HBase的FlushLargeStoresPolicy多例族支持

热门文章

  1. iOS开发网络数据之AFNetworking使用1
  2. BZOJ 3359: [Usaco2004 Jan]矩形( dp )
  3. java - final和static 关键字 再记忆
  4. 目录 of 2013-2014-1(内容已更新结束)
  5. handler.postDelayed()和timerTask
  6. CEOI2014 day1 task3 Question
  7. php导出excel数据
  8. if(男深圳集体户口&amp;&amp;女非深圳户口)深圳准生证办理材料及流程
  9. Moss、SharePoint数据库迁移问题(转)
  10. Jquery文本框小例(必填框)