Mondriaan's Dream

题目链接

Problem Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.



Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input file contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2

1 3

1 4

2 2

2 3

2 4

2 11

4 11

0 0

Sample Output

1

0

1

2

3

5

144

51205

经典的一道轮廓线dp题

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> PII;
#define inf 0x3f3f3f3f
const ll INF = 0x3f3f3f3f3f3f3f3f;
const ll MAXN = 1e6 + 7;
const ll MAXM = 1e3 + 7;
const ll MOD = 1e9 + 7;
const double eps = 1e-6;
int n, m, cur;
ll dp[2][1 << 15]; //滚动数组
void update(int from, int to)
{
if (to & (1 << m)) //判断溢出的一位是不是1,是0则不合法
dp[cur][to ^ (1 << m)] += dp[cur ^ 1][from];
}
int main()
{
while (~scanf("%d%d", &n, &m) && n && m)
{ if ((n * m) & 1) //总格子是奇数自然不行
printf("0\n");
else
{
cur = 0;
if (m > n)
swap(n, m);
int top = 1 << m;
dp[cur][top - 1] = 1; //轮廓线上方
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
cur ^= 1;
memset(dp[cur], 0, sizeof(dp[cur]));
for (int k = 0; k < top; k++) /* 转移轮廓线上的状态 */
{
/* 不放 直接转移*/
update(k, k << 1);
/* 往上放 上为0,当I=0时不可往上摆*/
if (i && !(k & (1 << m - 1)))
update(k, (k << 1) ^ (1 << m) ^ 1);
/* 往左放 左为0,上为1 ,j=0时不可往左摆*/
if (j && !(k & 1))
update(k, (k << 1) ^ 3);
}
}
}
printf("%lld\n", dp[cur][(1 << m) - 1]);
}
}
return 0;
}

最新文章

  1. Redis数据结构详解(一)
  2. meta http-equiv=&#39;refresh&#39; 解读
  3. Stationary point
  4. linux下inotify的使用
  5. Android.mk 常用宏和变量
  6. 强大的grep命令
  7. Swift - 使用NSNotificationCenter发送通知,接收通知
  8. java tools: jstat
  9. 国内外最全的asp.net开源项目 (转)
  10. iOS截屏代码
  11. Oracle User Management FAQ翻译及学习笔记
  12. Steve Yegge:Google面试秘籍
  13. iOS多线程的初步研究
  14. Codeforces Round #418 (Div. 2).C two points
  15. Redis集群伸缩
  16. Spring MVC基础知识整理➣数据校验与格式化
  17. E0264 Unable to execute &#39;&quot;/usr/bin/codesign&quot; ...&#39;
  18. ADB环境变量的配置
  19. 【物联网智能网关-17】.NET Micro Framework之MDK C++二次开发
  20. 使用 webpack 优化资源

热门文章

  1. Swagger Editor 本地搭建
  2. nor flash之频率限制
  3. 分布式大牛详解Zookeeper底层原理
  4. CodeForces 1182D
  5. ansible批量部署nginx
  6. 使用Django进行后端开发
  7. j接近50道经典SQL练习题,附建表SQL解题SQL
  8. 1050 螺旋矩阵 (25 分)C语言
  9. springmvc接收json数据的常见方式
  10. PHP的一些安全设置