Borg Maze
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14165   Accepted: 4619

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated
subspace network that insures each member is given constant supervision and guidance. 



Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is
that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost
of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character,
a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there
is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
#####
#A#A##
# # A#
#S ##
#####
7 7
#####
#AAA###
# A#
# S ###
# #
#AAA###
#####

Sample Output

8
11

Source

—————————————————————————————————————
题意:在一个迷宫里,起点是S,A代表外星人,我们需要找到最短的路径将S和所有的A连接起来,输出最短的这个路径总长
思路:先bfs建图,再最小生成树处理

注意:测试数据多了莫名其妙的空格,getchar()会wa,看了discuss在知道,智商题浪费时间

#include <iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<set>
#include<cstring>
using namespace std;
#define LL long long struct node
{
int u,v,w;
} p[1000005]; struct point
{
int x,y,t;
}; char mp[105][105];
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
int vis[105][105]; int n,m,cnt,tot,pre[10005]; bool cmp(node a,node b)
{
return a.w<b.w;
}
void init()
{
for(int i=0; i<10005; i++)
pre[i]=i;
} int fin(int x)
{
return pre[x]==x?x:pre[x]=fin(pre[x]);
} void kruskal()
{
sort(p,p+cnt,cmp);
init();
int cost=0;
int ans=0;
for(int i=0; i<cnt; i++)
{
int a=fin(p[i].u);
int b=fin(p[i].v);
if(a!=b)
{
pre[a]=b;
cost+=p[i].w;
ans++;
}
if(ans==tot-1)
{
break;
}
}
printf("%d\n",cost);
} bool check(int x,int y)
{
if(x<0||x>=n||y<0||y>=m||mp[x][y]=='#')
return 0;
return 1;
} void build(int x,int y)
{
memset(vis,0,sizeof vis);
point f,d;
f.x=x;
f.y=y;
f.t=0;
vis[x][y]=1;
queue<point>q;
q.push(f);
while(!q.empty())
{
f=q.front();
q.pop();
if((mp[f.x][f.y]=='A'||mp[f.x][f.y]=='S')&&(f.x!=x||f.y!=y))
{
p[cnt].u=100*x+y;
p[cnt].v=100*f.x+f.y;
p[cnt++].w=f.t;
}
for(int i=0; i<4; i++)
{
int xx=f.x+dir[i][0];
int yy=f.y+dir[i][1];
if(!vis[xx][yy]&&check(xx,yy))
{
d.x=xx;
d.y=yy;
d.t=f.t+1;
vis[xx][yy]=1;
q.push(d);
}
}
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&m,&n);
char temp[51];
gets(temp);
for(int i=0; i<n; i++)
gets(mp[i]);
cnt=0,tot=0;
for(int i=0; i<n; i++)
for(int j=0; j<m; j++)
if(mp[i][j]=='A'||mp[i][j]=='S')
build(i,j),tot++;
kruskal();
}
return 0;
}


最新文章

  1. Android之android:launchMode
  2. Fiddler 使用备忘
  3. HttpClient封装工具类
  4. 我的电脑右下角的日期也不见了只剩下时间,Win7系统,请问是什么原因啊?
  5. Dive into python 实例学python (1) —— 函数和测试
  6. POJ 2003 Hire and Fire (Tree)
  7. ios 记录支付宝集成遇到的坑及解决方法
  8. yii 删除内容时增加ajax提示
  9. RQNOJ PID2 / 开心的金明
  10. Ubuntu安装Anaconda3
  11. [Swift]LeetCode423. 从英文中重建数字 | Reconstruct Original Digits from English
  12. 『Asp.Net 组件』Asp.Net 服务器组件 的开发优势和劣势
  13. C#工具:防sql注入帮助类
  14. Trident Topology开发Demo
  15. [TensorBoard] Name &amp; Variable scope
  16. 【跟着开涛学Shiro】(一)Shiro简介
  17. SpringBoot日记——实战篇——Url定向
  18. 详细MATLAB 中BP神经网络算法的实现
  19. 怎样设置table中td的高度为1px
  20. 26、springboot与消息

热门文章

  1. JSP复习(part 3 )
  2. Hibernate 中 联合主键映射 组合关系映射 大对象映射(或者说文本大对象,二进制数据大对象)
  3. 使用VisualSVN Server搭建SVN服务器[xyytit]
  4. 带环链表 linked list cycle
  5. postman 使用 - 连接不到接口
  6. MVC中构建Linq条件、排序、Selector字段过滤
  7. DataTableExtensions
  8. 删除SVN版本控制目录
  9. 阈值分割与XLD轮廓拼接——第4讲
  10. Python高级用法篇——笔记