I - Doing Homework again

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores. 
 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 
 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
 

Sample Output

0
3
5
my answer:
#include<iostream>
#include<algorithm>
using namespace std;
typedef struct st{
int day;
int score;
}st;
bool cmp(st a,st b){
return a.score>b.score;
}
int main()
{
int n,T;
cin>>T;
while(cin>>n)
{
st a[1000];
int vis[1000]={0};
for(int i=0;i!=n;i++)
cin>>a[i].day;
for(int i=0;i!=n;i++)
cin>>a[i].score;
int b[1000];
sort(a,a+n,cmp);
int sum=0;
for(int j=0;j<n;j++){
if(vis[a[j].day]){ int k=a[j].day;
while(k>0&&vis[k])k--;
if(k<=0){sum+=a[j].score;}
else vis[k]=1;
}
else
{
vis[a[j].day]=1;
}
}
cout<<sum<<endl;
}
return 0;
}

最新文章

  1. Visual Studio 2015 Pre Secondary Installer 在哪里
  2. JavaScript 学习小结
  3. jQuery知识点总结(第六天)
  4. Java创建目录 mkdir与mkdirs的区别
  5. PostgreSQL Replication之第十二章 与Postgres-XC一起工作(2)
  6. 用Qt图形视图框架开发拼图游戏
  7. Sprite的原点
  8. 下一个系列学习列表Spring.net+NHibernate+MVC
  9. hdu-5505(数论)
  10. Openfire 服务端在Eclipse上部署
  11. Java序列化接口的作用总结
  12. Bat 中特殊符号
  13. 谈谈我对Java中CallBack的理解
  14. 《白手起家Win32SDK应用程序》(完整版+目录)
  15. OCP-1Z0-051-名称解析-文章32称号
  16. Spring+SpringMVC+MyBatis深入学习及搭建(十五)——SpringMVC注解开发(基础篇)
  17. git中常用的指令
  18. webstom破解
  19. WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!问题
  20. Promise笔记

热门文章

  1. HDU 4729 An Easy Problem for Elfness (主席树,树上第K大)
  2. centos防火墙端口配置
  3. HTTP头信息(转)--2
  4. 显示GetLastError()的错误描述字符串
  5. 21个值得收藏的Javascript技巧
  6. StormAPI简单使用
  7. css3——webkit-animation动画
  8. HTML豆ちしき
  9. silverlight依赖属性
  10. JS中String的反转函数