The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8

6 3 1 2 5 4 8 7

2 5

8 7

1 9

12 -3

0 8

99 99

Sample Output:

LCA of 2 and 5 is 3.

8 is an ancestor of 7.

ERROR: 9 is not found.

ERROR: 12 and -3 are not found.

ERROR: 0 is not found.

ERROR: 99 and 99 are not found.

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
int m, n, u, v, a;
scanf("%d %d", &m, &n);
vector<int> pre(n);
for (int i = 0; i < n; i++) {
scanf("%d", &pre[i]);
mp[pre[i]] = true;
}
for (int i = 0; i < m; i++) {
scanf("%d %d", &u, &v);
for(int j = 0; j < n; j++) {
a = pre[j];
if ((a > u && a < v)|| (a > v && a < u) || (a == u) || (a == v)) break;
}
if (mp[u] == false && mp[v] == false)
printf("ERROR: %d and %d are not found.\n", u, v);
else if (mp[u] == false || mp[v] == false)
printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
else if (a == u || a == v)
printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
else
printf("LCA of %d and %d is %d.\n", u, v, a);
}
return 0;
}

最新文章

  1. MySQL的InnoDB索引原理详解 (转)
  2. linux下查找某文件关键字
  3. 秒杀9种排序算法(JavaScript版)
  4. C# Listview 第一列不能居中
  5. 【C++】快排
  6. dom对象详解--document对象(一)
  7. UC编程之网络通信(TCP/UDP)
  8. SAE J1708 DS36277 MAX3444, DS75176B
  9. 《JavaScript模式》读书笔记
  10. 【HTML】Advanced1:Text: Time, Mark, and &quot;Presentational&quot;
  11. light oj 1354 - IP Checking
  12. RHEL6从源码安装python及其他软件包
  13. ssh连接所生成的known_hosts出现的问题
  14. AI学习吧
  15. 依赖配置中心实现注有@ConfigurationProperties的bean相关属性刷新
  16. npoi设置数据有效性
  17. nginx静态文件缓存的解决方案
  18. MongoDB 安装及副本集简单操作
  19. OpenCV 学习笔记 01 安装OpenCV及相关依赖库
  20. (转)如何修复ubuntu的UEFI引导

热门文章

  1. bzoj4870
  2. 10. Extjs Button控件的handler配置项和click事件
  3. 10.17NOIP模拟赛
  4. eccharts-gl 3D立体柱状图
  5. 51nod1344 走格子
  6. RabbitMQ~广播消息
  7. Cesium加载影像
  8. 6.13---shiro
  9. IIS配置负载均衡
  10. C语言中结构体大小计算