Walk Out

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 141    Accepted Submission(s): 17

Problem Description
In an n∗m maze,
the right-bottom corner is the exit (position (n,m) is
the exit). In every position of this maze, there is either a 0 or
a 1 written
on it.



An explorer gets lost in this grid. His position now is (1,1),
and he wants to go to the exit. Since to arrive at the exit is easy for him, he wants to do something more difficult. At first, he'll write down the number on position (1,1).
Every time, he could make a move to one adjacent position (two positions are adjacent if and only if they share an edge). While walking, he will write down the number on the position he's on to the end of his number. When finished, he will get a binary number.
Please determine the minimum value of this number in binary system.
 
Input
The first line of the input is a single integer T (T=10),
indicating the number of testcases. 



For each testcase, the first line contains two integers n and m (1≤n,m≤1000).
The i-th
line of the next n lines
contains one 01 string of length m,
which represents i-th
row of the maze.
 
Output
For each testcase, print the answer in binary system. Please eliminate all the preceding 0 unless
the answer itself is 0 (in
this case, print 0 instead).
 
Sample Input
2
2 2
11
11
3 3
001
111
101
 
Sample Output
111
101
 
Source

求从1,1到n。n的路径中。得到的二进制数最小是什么

方法:

假设1,1是0那么搜索出全部可达的0号点,前缀0为0,所以能够从这些位置出发。

然后有了一个1,。

那么仅仅要路径最短的,同一时候得到的二进制数最小的。

从全部可出发的点出发,做bfs,计算到n,n的最短路。

然后从n,n做bfs看,那些位置是在最短路上的。

然后从全部可出发的点出发,bfs。

假设存在能到的0点。

则从这些点出发。否则从到的1点出发。

这样贪心做就可以。直到到n。n点

#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define maxn 1001 char ma[maxn][maxn];
int check[maxn][maxn];
int dep[maxn][maxn]; struct Node{
int x,y;
Node(int _x=0,int _y=0):x(_x),y(_y){}
}; queue<Node> que;
vector<int> ans;
vector<Node> one;
vector<Node> zero;
int n,m;
void dfs(int x,int y){
if(check[x][y] || x == n || y == m || x < 0 || y < 0 || ma[x][y] == '1') return;
que.push(Node(x,y));
check[x][y] = 1;
dfs(x+1,y);
dfs(x,y+1);
dfs(x-1,y);
dfs(x,y-1);
}
void work(){
while(que.size() > 0)
que.pop();
if(ma[0][0] == '1'){
check[0][0] = 1;
que.push(Node(0,0));
}
else {
dfs(0,0);
}
}
void bfs(){
Node a;
while(que.size() > 0){
a = que.front();
que.pop();
if(a.x + 1 < n && a.y < m && check[a.x+1][a.y] == 0){
que.push(Node(a.x+1,a.y));
check[a.x+1][a.y] = 1;
dep[a.x+1][a.y] = dep[a.x][a.y] + 1;
}
if(a.x < n && a.y + 1 < m && check[a.x][a.y+1] == 0){
que.push(Node(a.x,a.y+1));
check[a.x][a.y+1] = 1;
dep[a.x][a.y+1] = dep[a.x][a.y] + 1;
}
}
}
int mark[maxn][maxn];
void nidfs(int x,int y){
mark[x][y] = 1;
if(x-1>=0 && y >= 0 && mark[x-1][y] == 0 && dep[x-1][y] == dep[x][y] - 1 && dep[x-1][y] > 0)
nidfs(x-1,y);
if(x >= 0 && y-1>=0 && mark[x][y-1] == 0 && dep[x][y-1] == dep[x][y] - 1 && dep[x][y-1] > 0)
nidfs(x,y-1);
} void getans(){
ans.clear();
Node a;
while(1){
one.clear();
zero.clear();
while(que.size() > 0){
a = que.front();
que.pop();
if(a.x == n -1 && a.y == m -1 ) return ;
if(a.x + 1 < n && a.y < m && check[a.x+1][a.y] == 0&& dep[a.x+1][a.y] == dep[a.x][a.y] + 1 && mark[a.x+1][a.y]){
if(ma[a.x+1][a.y] == '1') one.push_back(Node(a.x+1,a.y));
else zero.push_back(Node(a.x+1,a.y));
check[a.x+1][a.y] = 1;
}
if(a.x < n && a.y + 1< m && check[a.x][a.y+1] == 0 && dep[a.x][a.y+1] == dep[a.x][a.y] + 1 && mark[a.x][a.y+1]){
if(ma[a.x][a.y+1] == '1') one.push_back(Node(a.x,a.y+1));
else zero.push_back(Node(a.x,a.y+1));
check[a.x][a.y+1] = 1;
}
}
if(zero.size() > 0){
ans.push_back(0);
for(int i = 0;i < zero.size();i++)
que.push(zero[i]);
}
else {
ans.push_back(1);
for(int i = 0;i < one.size();i++)
que.push(one[i]);
}
}
}
int main(){
int t;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
for(int i = 0;i < n; i++){
scanf("%s",ma[i]);
}
memset(check,0,sizeof(check));
work();
memset(dep,0,sizeof(dep));
bfs();
// for(int i = 0;i < n; i++){
// for(int j = 0;j < m; j++){
// printf("%d ",dep[i][j]);
// }cout<<endl;
// }
// cout<<endl;
memset(mark,0,sizeof(mark));
nidfs(n-1,m-1); memset(check,0,sizeof(check));
work();
getans();
// for(int i = 0;i < n; i++){
// for(int j = 0;j < m; j++){
// printf("%d ",dep[i][j]);
// }cout<<endl;
// }
if(ans.size() == 0 && ma[0][0] =='0'){
printf("0\n");
}
else {
if(ma[0][0] == '1') printf("1");
for(int i = 0;i < ans.size(); i++)
printf("%d",ans[i]);
printf("\n");
} }
return 0; }
/*
20
2 2
11
11
3 3
001
111
101
3 3
111
111
111
3 3
000
000
000
3 3
001
011
111
*/

最新文章

  1. 纯CCS绘制三角形箭头图案
  2. oracle数据库的乱码问题解决方案
  3. python学习笔记一 python入门(基础篇)
  4. ajax再接触
  5. VVDocumenter - Xcod代码注释工具
  6. 关于C++的变量和类的声明和定义
  7. android 删除的警告对话框
  8. MTKdroidToolsV2.53 MTK安卓提取线刷资料的工具 使用教程
  9. Win7网络检测 WindowsAPICodePack
  10. Java程序员需要学习的知识点
  11. ajax实例及实现文本框异步搜素
  12. jquery的ajax与spring mvc对接注意事项
  13. 移动端web app开发学习笔记
  14. OpenStack共享组件
  15. BZOJ 5467 Slay the Spire
  16. 自动代码质量分析(GitLab+JenKins+SonarQube)
  17. sql server 2008数据库 降为 sql server 2005数据库 最终方案总结
  18. 实现点击到底部、顶部、指定div功能
  19. 下一代的DevOps服务:AIOps
  20. python面向对象(七)属性方法的添加

热门文章

  1. hdu 4888 2014多校第三场1002 Redraw Beautiful Drawings 网络流
  2. QT5 Failed to load platform plugin &amp;quot;windows&amp;quot; 终极解决方式 命令行问题
  3. 深刻理解Java中的String、StringBuffer和StringBuilder的差别
  4. Visual studio 编译时copy文件、文件夹
  5. bzoj1786: [Ahoi2008]Pair 配对&amp;&amp;1831: [AHOI2008]逆序对
  6. Linux性能优化和监控系列(一)——top工具
  7. [jzoj 6093] [GDOI2019模拟2019.3.30] 星辰大海 解题报告 (半平面交)
  8. QEMU/KVM磁盘在线备份
  9. mybatis、spring、mysql、maven实现简单增删查改
  10. Spring《五》集合的注入方式