Description

 

A set of n<tex2html_verbatim_mark> 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l<tex2html_verbatim_mark> and each item i<tex2html_verbatim_mark> has length lil<tex2html_verbatim_mark> . We look for a minimal number of bins q<tex2html_verbatim_mark> such that

  • each bin contains at most 2 items,
  • each item is packed in one of the q<tex2html_verbatim_mark> bins,
  • the sum of the lengths of the items packed in a bin does not exceed l<tex2html_verbatim_mark> .

You are requested, given the integer values n<tex2html_verbatim_mark> , l<tex2html_verbatim_mark> , l1<tex2html_verbatim_mark> , ..., ln<tex2html_verbatim_mark> , to compute the optimal number of bins q<tex2html_verbatim_mark> .

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The first line of the input file contains the number of items n<tex2html_verbatim_mark>(1n105)<tex2html_verbatim_mark> . The second line contains one integer that corresponds to the bin length l10000<tex2html_verbatim_mark> . We then have n<tex2html_verbatim_mark> lines containing one integer value that represents the length of the items.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each input file, your program has to write the minimal number of bins required to pack all items.

Sample Input

1

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output

6

Note: The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.

这道首先使用使用贪心的思路,先模拟贪心过程:给出一个桶,那么这个桶能装两个就两个,不行就算了
具体实现:把数组从小到大排序,然后使用两个变,一个在左,一个在右,首先以右边为据,在左边尽量找一个和它放在一个桶里,如果成功就有i++和j--,直到i和j相遇,跳出循环,统计这时已拿出的桶的数量,即为答案
 
#include"iostream"
#include"algorithm"
using namespace std; const int maxn=100000+10; int n,l;
int a[maxn]; void Init()
{
cin>>n>>l;
for(int i=0;i<n;i++) cin>>a[i];
} void Work()
{
sort(a,a+n);
int j=0,ans=0;
for(int i=n-1;i>=0;i--)
{
if(i<j) break;
ans++;
while(a[i]+a[j]<=l&&i>j)
{
j++;
break;
}
}
cout<<ans<<endl;
} int main()
{
int T,t;
cin>>T;
t=T;
while(T--)
{
if(t!=T+1) cout<<endl;
Init();
Work();
}
return 0;
}

最新文章

  1. 【转】精选30个优秀的CSS技术和实例
  2. Java基本数据类型与位运算
  3. Oracle重新装机后如何快速还原以前表和用户
  4. Android学习笔记(九) 视图的应用布局效果
  5. [转]PDF预览插件PDFObject.js
  6. 计算几何 HDOJ 4720 Naive and Silly Muggles
  7. CoreLocation
  8. How Tomcat Works(十八)
  9. 四.CSS声明
  10. CentOS6.5解决中文乱码与设置字符集
  11. (转)webstorm快捷键
  12. 九种迹象表明你该用Linux了
  13. React Native随笔——警告处理方法(持续更新)
  14. VS2019 更新MSDN并创建快捷方式
  15. VB输出数据到EXCEL
  16. zookeeper的安装与使用
  17. 剑指Offer 21. 栈的压入、弹出序列 (栈)
  18. cf-Global Round2-C. Ramesses and Corner Inversion(思维)
  19. 〖Linux〗实时更新 hosts 文件的脚本
  20. activiti 数据表设计

热门文章

  1. USACO Training刷题记录 By cellur925
  2. 团队作业-项目Alpha版本发布
  3. Allure对单测结果以及robotframework结果的处理
  4. linux 查看进程和端口
  5. 转-MAC 下安装PHONEGAP开发环境
  6. outlook 通讯录分类--2017年1月16日--对联系人分类管理
  7. 开发一个 Web App 必须了解的那些事
  8. 浅析套接字中SO_REUSEPORT和SO_REUSEADDR的区别
  9. DeltaFish 选题报告总结
  10. iOS----创建静态库