Time Limit: 500MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Submit
Status

Description

See the picture below.

You are given AB, AC and BC.
DE is parallel to BC. You are also given the area ratio between
ADE and BDEC. You have to find the value of
AD
.

Input

Input starts with an integer T (≤ 25), denoting the number of test cases.

Each case begins with four real numbers denoting AB, AC, BC and the ratio of
ADE and BDEC(ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.

Output

For each case of input you have to print the case number and AD. Errors less than
10-6 will be ignored.

Sample Input

4

100 100 100 2

10 12 14 1

7 8 9 10

8.134 9.098 7.123 5.10

Sample Output

Case 1: 81.6496580

Case 2: 7.07106781

Case 3: 6.6742381247

Case 4: 7.437454786

Source

Problem Setter: Jane Alam Jan



现在给出了AB,AC,BC以及三角形与梯形面积比值,求AD

#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
int t;
int K=1;
scanf("%d",&t);
while(t--)
{
double a,b,c,k;
scanf("%lf%lf%lf%lf",&a,&b,&c,&k);
double ad=a*sqrt(k/(1+k));
printf("Case %d: %.6lf\n",K++,ad);
}
return 0;
}

最新文章

  1. oracle实用sql之将逗号分割的字符串分割多个列
  2. Maven-010-maven 编译报错:Failure to ... in ... was cached in the local repository, resolution will not be reattempted until the update interval of nexus has elapsed or updates are forced.
  3. zepto - toggleClass
  4. emacs设置代理访问插件仓库
  5. Careercup - Google面试题 - 4877486110277632
  6. align=absMiddle属性设置
  7. [转]Speeding Up Websites With YSlow
  8. Sublime Text个性化设置
  9. 在MyEclipse中如何去掉JS或jsp语法错误提示!
  10. a标签的target的四个值
  11. 面试相关-转载-well,yzl——持续更新
  12. Java项目转换成Web项目
  13. Asp.Net SignalR - 简单聊天室实现
  14. Oracle 索引 index
  15. Ubuntu 安装YouCompleteMe
  16. 加密流量分析cisco
  17. 1170 - BLOB/TEXT column &#39;CustomerName&#39; used in key specification without a key length
  18. POJ1442-查询第K大-Treap模板题
  19. Mycat实现mysql主从复制(读写分离)
  20. Visual Studio 2017中使用正则修改部分内容

热门文章

  1. javascript中实现继承的几种方式
  2. js递归获取html页面所有标签
  3. 从A小程序跳转到B小程序
  4. collections模块-namedtuple
  5. 洛谷 P1373 小a和uim之大逃离 (差值型dp总结)
  6. Google的10大座右铭
  7. HDU 1827 Summer Holiday(强连通)
  8. unix中文件I/O
  9. 【Android】资源系列(二) -- 文件原样保留的资源assets和res/raw文件夹
  10. orale 中创建定时任务