题先附上:水题,可是思路不正确,特easy超时(TLE)

The shortest problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1084    Accepted Submission(s): 534

Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat
it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 
Input
Multiple input.

We have two integer n (0<=n<=104 )
, t(0<=t<=105)
in each row.

When n==-1 and t==-1 mean the end of input.
 
Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 
Sample Input
35 2
35 1
-1 -1
 
Sample Output
Case #1: Yes
Case #2: No
 
Source
 

自己写的过程:

连交几发都是超时。超内存;

做题一定要注意:思路清晰。思维迅速敏捷。

想好再写代码,不要还没思路就动手敲。什么也敲不出来。

自己又写了一遍AC了
同一时候。在看他的代码时学到了另外的一些东西。
自己做题时的模版基本上写每道题时,套的库呀,另一些经常使用的宏定义,以及一些常量。自己都能够做成属于自己的模版。

以后再写题时,就不用每次都敲一遍了。




这道题的代码:

#include<iostream>
#include<cstdio>
#include<algorithm> using namespace std; int n;
long t; int main()
{
long js,os,i,j=0,k,m,p,q;
while(cin>>n>>t){
if(n==-1&&t==-1)break;
j++;
js=n%10+(n/100)%10+(n/10000)%10;
os=(n/10)%10+(n/1000)%10;
for(i=1;i<=t;i++){
k=p=q=0;
m=js+os;
while(m){
k++;
if(k%2)p+=m%10;
else q+=m%10;
m/=10;
}
if(k%2){
js+=q;
os+=p;
swap(js,os);
}
else {
js+=p;
os+=q;
}
}
if((js-os)%11)cout<<"Case #"<<j<<": No"<<endl;
else cout<<"Case #"<<j<<": Yes"<<endl;
}
return 0;
}

最新文章

  1. Birt报表存储过程多选参数的设置
  2. 前端学PHP之面向对象系列第五篇——对象操作
  3. windows加入path路径
  4. linux tar order
  5. fastjson 使用方法
  6. 《你是我的小羊驼》游戏源码 v1.0
  7. JavaScript 基础二
  8. RequiredFieldValidator验证下拉列表框
  9. 无效 URI: 故障分析证书颁发机构/主机
  10. cocos2d-x 实现跨平台的目录遍历
  11. VB webbrowser 控件的应用(跨域 内嵌网页元素的访问)
  12. ACM 刷题小技巧【转】
  13. CSS3阴影 box-shadow的使用总结
  14. MySQL via EF6 的试用报告
  15. cmake简明使用指南
  16. python正则表达式补充
  17. Python 字符串增删改查的使用
  18. CSS实现鼠标悬浮无限向下级展示的简单代码
  19. vue2.0学习笔记之路由(二)路由嵌套
  20. JAVA项目将 Oracle 转 MySQL 数据库转换(Hibernate 持久层)

热门文章

  1. Python socket粘包问题(最终解决办法)
  2. hihoCoder挑战赛29
  3. spring AOP详解二
  4. [图论训练]1143: [CTSC2008]祭祀river 二分图匹配
  5. 刷题总结——生产产品(vijo1243)
  6. 算法复习——最小表示法(bzoj2882)
  7. .sh 和 .ksh —— 三种主要的 Shell简介(Korn shell)
  8. [POI2005]SKA-Piggy Banks (Tarjan缩点)
  9. JAVA Apache POI 之sax 解析10万级大数量数据
  10. lucas定理 +证明 学习笔记