Description

Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of Aizu, had decided to
grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field. Inside the field which had also
a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as 'Mishirazu Persimmon', were planted. Since persimmon was Hayashi's favorite fruit, he wanted to have as many persimmon trees as possible
in the estate given by the lord. 

For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded
by the solid line contains the most persimmon trees. Similarly, if the estate's width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate's width and height are 3 and 4 respectively, the area surrounded by the dotted
line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1. 

 

Figure 1: Examples of Rectangular Estates


Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.

Input

The input consists of multiple data sets. Each data set is given in the following format. 





W H 

x1 y1 

x2 y2 

... 

xN yN 

S T 



N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <=
N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees
are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H. 



The end of the input is indicated by a line that solely contains a zero. 

Output

For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.

Sample Input

16
10 8
2 2
2 5
2 7
3 3
3 8
4 2
4 5
4 8
6 4
6 7
7 5
7 8
8 1
8 4
9 6
10 3
4 3
8
6 4
1 2
2 1
2 4
3 4
4 2
5 3
6 1
6 2
3 2
0

Sample Output

4
3

Source



题意:
有N棵树在一个n*m的田里,给出每颗树的坐标
用一个s*t的矩形去围,最多能围几棵树

思路:
简单的二维树状数组

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std; #define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 1005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)
const int mod = 1e9+7; int c[N][N],n,m,cnt,s,t; int sum(int x,int y)
{
int ret = 0;
int i,j;
for(i = x;i>=1;i-=lowbit(i))
{
for(j = y;j>=1;j-=lowbit(j))
{
ret+=c[i][j];
}
}
return ret;
} void add(int x,int y,int d)
{
int i,j;
for(i = x;i<=n;i+=lowbit(i))
{
for(j = y;j<=m;j+=lowbit(j))
{
c[i][j]+=d;
}
}
} int main()
{
int i,j,x,y,ans;
while(~scanf("%d",&cnt),cnt)
{
ans = 0;
scanf("%d%d",&n,&m);
MEM(c,0);
for(i = 1;i<=cnt;i++)
{
scanf("%d%d",&x,&y);
add(x,y,1);
}
scanf("%d%d",&s,&t);
for(i = 1;i<=n;i++)
{
for(j = 1;j<=m;j++)
{
int x1 = i,y1 = j,x2 = x1+s-1,y2 = y1+t-1;
if(x2>n || y2>m) continue;
int s = sum(x2,y2)+sum(x1-1,y1-1)-sum(x2,y1-1)-sum(x1-1,y2);
ans = max(ans,s);
}
}
printf("%d\n",ans);
} return 0;
}

最新文章

  1. Javascript提交表单
  2. 基于stm32f4的ucGUI通过外部flash存储汉字库显示任意英文字符和汉字组合(控件可用)
  3. 狗汪汪玩转无线电 -- GPS Hacking
  4. sql case when then else end
  5. PE文件格式 持续更新ing
  6. Maching Learning 学习资料
  7. unity3d中asset store 的资源下载到本地的目录位置
  8. UDP 打洞 原理解释
  9. platform_driver_register()--如何match之后调用probe
  10. linux设备驱动那点事儿之平台设备理论篇
  11. mac下firefox复制粘贴失效解决办法
  12. mysql 批量删除分区
  13. OS X 和iOS 中的多线程技术(下)
  14. WMI入门教程之WMI中的类在哪里?
  15. web框架开发-Django用户认证组件
  16. 关于ddl(新增字段)对数据库锁表|读写操作的影响_资料
  17. [UE4]显示落地箭头
  18. redmine增加文本输入框默认格式
  19. 笔记本移动位置,切换网络ip后,虚拟机的mac系统无法联网解决
  20. Hadoop生态圈-Flume的组件之自定义Sink

热门文章

  1. Tensorflow 学习笔记 -----gradient
  2. 学习《R数据科学》高清中文PDF+高清英文PDF+源代码
  3. mysql查一张表有哪些索引
  4. cocos2dx 3.0正式版 在mac上新建项目
  5. Peer To Peer——对等网络
  6. Intel TBB in OpenCASCADE
  7. Hadoop-2.6.0上的C的API訪问HDFS
  8. 新辰:十种外链终极方法 让SEOer外链之路不再孤独!
  9. VS NuGet使用
  10. 错误日志写入到本地磁盘(lock 队列)