题目链接:

思路是:首先依据图像抽象出联通关系。。

首先确定每一种图形的联通关系。用01值表示不连通与不连通。。。

然后从第1个图形进行dfs搜索。假设碰到两快田地能够联通的话那么标记。。注意处理的过程中你的

搜索顺序要和你的每一个图形的连通性的顺序同样。

。然后就是最后看上下。

左右是否能匹配。。

看最后有几个不同的快,这就是答案,感觉跟并查集一样。。并查集应该也能够做。


题目:

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5696    Accepted Submission(s): 2474

Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A
to K, as Figure 1 shows.






Figure 1




Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 



ADC

FJK

IHE



then the water pipes are distributed like 






Figure 2




Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 



Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 



Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 
Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative
M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 
Output
For each test case, output in one line the least number of wellsprings needed.
 
Sample Input
2 2
DK
HF 3 3
ADC
FJK
IHE -1 -1
 
Sample Output
2
3
 
Author
ZHENG, Lu
 
Source
 
Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1232 1213 

pid=1856" target="_blank" style="color:rgb(26,92,200); text-decoration:none">1856 1811 1829 

代码为:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std; int n,m,ans;
const int maxn=50+10;
int map[maxn][maxn]; int dX[]={-1,0,1,0};
int dY[]={0,1,0,-1}; int pipe[11][4]={{1,0,0,1},{1,1,0,0},{0,0,1,1},{0,1,1,0},{1,0,1,0},{0,1,0,1},{1,1,0,1},{1,0,1,1},{0,1,1,1},{1,1,1,0},{1,1,1,1}};
int hash[maxn][maxn]; bool check(int row,int col)
{
if(row>=0&&row<n&&col>=0&&col<m&&!hash[row][col])
return true;
return false;
} void dfs(int row,int col)
{
hash[row][col]=1;
for(int k=0;k<4;k++)
{
int dx=row+dX[k];
int dy=col+dY[k];
if(check(dx,dy)&&pipe[map[row][col]][k]==1&&pipe[map[dx][dy]][(k+2)%4]==1)
dfs(dx,dy);
}
} void solve()
{
memset(hash,0,sizeof(hash));
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
if(!hash[i][j])
{
dfs(i,j);
ans++;
}
}
} int main()
{
char str[maxn];
while(~scanf("%d%d",&n,&m))
{
ans=0;
if(n<=0||m<=0) return 0;
for(int i=0;i<n;i++)
{
scanf("%s",str);
for(int j=0;j<m;j++)
map[i][j]=str[j]-'A';
}
solve();
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. TF-IDF提取行业关键词
  2. nodejs 小爬虫
  3. 【leetcode】Factorial Trailing Zeroes(easy)
  4. PHP面向对象程序设计的61条黄金法则
  5. Android实现静默安装与卸载
  6. Oracle和MSSQL查询有多少张表
  7. javascript模式——Factory
  8. (IOS)Apple 证书相关
  9. 【转】HTTP Response Header 的 Content-Disposition
  10. FFmpeg在Linux下安装编译过程
  11. 记录几个经典的字符串hash算法
  12. 如何去掉wordpress网站url里面的index.php(Apache服务器)
  13. Java子线程中操作主线程Private级别数据
  14. HDU3342Legal or Not 拓扑排序
  15. hive中的几个参数:元数据配置、仓库位置、打印表字段相关参数
  16. ELK学习笔记之Grok patterns正则匹配
  17. 用java修改文件的编码
  18. python 函数中使用全局变量
  19. 获取泛型类对应的class类型
  20. Mosquitto服务器的搭建以及SSL/TLS安全通信配置

热门文章

  1. CentOS下安装netcat
  2. 【bzoj4555】[Tjoi2016&amp;Heoi2016]求和 NTT
  3. arcgis engine10.1和arcObjects的一些问题
  4. 在Visual studio 2010中为C#的“///”注释内容生成XML文档 .
  5. [SDOI2009][bzoj1878] HH的项链 [莫队模板题]
  6. 【EX_BSGS】BZOJ1467 Pku3243 clever Y
  7. 【02】webpack 之 入门
  8. sublime 常用快捷键备忘
  9. android开发过程遇到的一些错误
  10. HashMap和TreeMap的常用排序方法