Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41230   Accepted: 16810

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
#include <cstdio>
#include<cstring>
#include <queue>
#include <assert.h>
using namespace std; int blen;
int d[102][102];
int n;
bool vis[102];
typedef pair<int,int> P;
int prim(){
memset(vis,0,sizeof(vis));
priority_queue<P,vector<P>,greater<P> >que;
int num=1;
int ans=0;
for(int i=1;i<n;i++){
que.push(P(d[0][i],i));
}
vis[0]=true;
while(num<n&&!que.empty()){
int t=que.top().second;
int td=que.top().first;
que.pop();
if(vis[t])continue;
vis[t]=true;
ans+=td;
num++;
for(int i=0;i<n;i++){
if(!vis[i]){
que.push(P(d[t][i],i));
}
}
}
return ans;
}
int main(){
while(scanf("%d",&n)==1){
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
scanf("%d",d[i]+j);
}
}
int ans=prim();
printf("%d\n",ans);
}
return 0;
}

  

最新文章

  1. 从APP跳转到WI-FI
  2. Python框架之Tornado(四)源码之褪去模板外衣的前戏
  3. 【JS复习笔记】03 继承
  4. Linux Bash Shell 快速入门
  5. if/else语句匹配问题
  6. Start-Process传递变量
  7. pair work-Elevator Schedule附加题
  8. storyBoard使用介绍
  9. centos curl web站点监控实践
  10. PHP memcache实现消息队列实例
  11. 经典HTML5小游戏 支持各种浏览器 (围住神经猫)
  12. APP后台API文档管理对接(APP后台框架五)
  13. VMware虚拟机中常见的问题汇总
  14. (字典序问题) nyoj1542-最小字符串
  15. MySql两种存储引擎的区别
  16. B. Planning The Expedition
  17. CNN-卷积层和池化层学习
  18. css ::selection 的妙用
  19. Git------解决右键不显示Git Bash Here问题
  20. LoadRunner-参数化(界面说明)

热门文章

  1. SecureCRT 7在ubuntu下的破解方法
  2. Linux使用free命令查看实际内存占用
  3. iPhone X 游戏闪退:NSUnknownKeyException
  4. openwrt下如何只编译uboot
  5. 何为K-邻近算法
  6. 采用OpenReplicator解析MySQL binlog
  7. LeetCode——Is Subsequence
  8. LeetCode——Arithmetic Slices
  9. codeforce 35C fire again
  10. Nginx 与 tomcat 部署网站