http://poj.org/problem?

id=1655

Balancing Act
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9072   Accepted: 3765

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node
from T. 

For example, consider the tree: 




Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these
trees has two nodes, so the balance of node 1 is two. 



For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers
that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

求树的重心。!

树的重心性质是以该点为根的有根树最大子树的结点数最少,也就是让这树更加"平衡",easy知道这样全部的子树的大小都不会超过整个树大小的一半,所以在树分治时防止树退化成链非常实用。

求树的重心做法是dfs简单的树dp即可。设son[i]表示以i为根的子树的结点数(包含i,叶子结点就是1),那么son[i]就+=sum(son[j])...然后求以i为根的最大结点数就是max(son[j],n-son[i]),n-son[i]是i的"上方结点"的个数。

关于树的重心一些性质:http://fanhq666.blog.163.com/blog/static/81943426201172472943638/

代码:

/**
* @author neko01
*/
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
const int N=20005;
struct node{
int to,next;
}e[N*2];
int head[N];
int son[N]; //son[i]表示以i为根的子树节点个数包含i
int dp[N]; //dp[i]表示以i为根时的最大子树节点数
int tot;
int n;
void init()
{
tot=0;
clr1(head);
}
void add(int u,int v)
{
e[tot].to=v;
e[tot].next=head[u];
head[u]=tot++;
}
void dfs(int u,int pre)
{
son[u]=1;
dp[u]=0;
for(int i=head[u];i!=-1;i=e[i].next)
{
int v=e[i].to;
if(v!=pre)
{
dfs(v,u);
son[u]+=son[v];
dp[u]=max(dp[u],son[v]);
}
}
dp[u]=max(dp[u],n-son[u]);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
init();
for(int i=1;i<n;i++)
{
int u,v;
scanf("%d%d",&u,&v);
add(u,v);
add(v,u);
}
dfs(1,0);
int ans1=0,ans2=n+1;
for(int i=1;i<=n;i++)
if(dp[i]<ans2)
{
ans2=dp[i];
ans1=i;
}
printf("%d %d\n",ans1,ans2);
}
return 0;
}

版权声明:本文博客原创文章,博客,未经同意,不得转载。

最新文章

  1. JS获取元素尺寸大小、鼠标位置
  2. struts2 拦截器和actioninvocation、PreResultListener
  3. EmguCV 轮廓
  4. 如何关闭Linux里边的selinux ?
  5. Linux开机启动chkconfig命令详解(让MySQL、Apache开机启动)
  6. Unity 3D 关于给APK包加广告的流程
  7. [转载] google mock cookbook
  8. Chapter Querying Data
  9. Appium 提高脚本复用、可配置性
  10. 【C#版本详情回顾】C#2.0主要功能列表
  11. PHP页面间的参数传递
  12. Spring事务传播机制和数据库隔离级别
  13. Object的方法
  14. 对混合数值,字符,null的字段进行排序
  15. 还在期待安卓9.0吗?Android 10.0要来了
  16. day 07 数据类型,集合,深浅copy
  17. Hlacon 之Image ,Region,XLD
  18. djjango models表关系
  19. ats 分层缓存
  20. Windows Phone background Audio 后台音频

热门文章

  1. POJ 3619 Speed Reading(简单题)
  2. hdu 4057 AC自己主动机+状态压缩dp
  3. Swift - 给表格添加Cell的显示动画(3D缩放)
  4. 几款屏幕录制软件 ActivePresente
  5. C++ operator overload -- 操作符重载
  6. CorePlot学习
  7. Swift - UIColor使用自定义的RGB配色
  8. Swift - 加速传感器(CoreMotion)的用法,小球加速运动并反弹样例
  9. svn强制用户提交时写日志
  10. [C#基础] 类