Intersecting Lines
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12421   Accepted: 5548

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two
lines in the x-y plane and determine how and where the lines intersect.
All numbers required by this problem will be reasonable, say between
-1000 and 1000.

Input

The
first line contains an integer N between 1 and 10 describing how many
pairs of lines are represented. The next N lines will each contain eight
integers. These integers represent the coordinates of four points on
the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines
represents two lines on the plane: the line through (x1,y1) and (x2,y2)
and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always
distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There
should be N+2 lines of output. The first line of output should read
INTERSECTING LINES OUTPUT. There will then be one line of output for
each pair of planar lines represented by a line of input, describing how
the lines intersect: none, line, or point. If the intersection is a
point then your program should output the x and y coordinates of the
point, correct to two decimal places. The final line of output should
read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

Source

题意:给定 1 - 10组直线,判断每组直线的关系,若相交 输出交点坐标,保留两位小数;若平行,输出‘NONE’;若重合,输出‘LINE’;

输出格式详见标准输出。

 #include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <math.h>
#include <algorithm>
#include <cctype>
#include <string>
#include <map>
#include <set>
#define ll long long
using namespace std;
const double eps = 1e-;
int sgn(double x)
{
if(fabs(x) < eps)return ;
if(x < ) return -;
else return ;
}
struct Point
{
double x,y;
Point(){}
Point(double _x,double _y)
{
x = _x;y = _y;
}
Point operator -(const Point &b)const
{
return Point(x - b.x,y - b.y);
}
double operator ^(const Point &b)const
{
return x*b.y - y*b.x;
}
double operator *(const Point &b)const
{
return x*b.x + y*b.y;
}
}; struct Line
{
Point s,e;
Line(){}
Line(Point _s,Point _e)
{
s = _s;e = _e;
}
pair<Point,int> operator &(const Line &b)const
{
Point res = s;
if(sgn((s-e)^(b.s-b.e)) == )
{
if(sgn((b.s-s)^(b.e-s)) == )
return make_pair(res,);//两直线重合
else return make_pair(res,);//两直线平行
}
double t = ((s-b.s)^(b.s-b.e))/((s-e)^(b.s-b.e));
res.x += (e.x - s.x)*t;
res.y += (e.y - s.y)*t;
return make_pair(res,);//有交点
}
}; int main(void)
{
int t;
double x1,x2,x3,x4,y1,y2,y3,y4;
scanf("%d",&t);
printf("INTERSECTING LINES OUTPUT\n");
while(t--)
{
scanf("%lf %lf %lf %lf %lf %lf %lf %lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);
Line l1 = Line( Point(x1,y1) ,Point(x2,y2) );
Line l2 = Line( Point(x3,y3) ,Point(x4,y4) );
pair<Point,int> ans = l1 & l2;
if(ans.second == ) printf("POINT %.2f %.2f\n",ans.first.x,ans.first.y);
else if(ans.second == ) printf("LINE\n");
else printf("NONE\n");
}
printf("END OF OUTPUT\n"); return ;
}

最新文章

  1. mac中使用brew安装软件,下载太慢怎么办?
  2. [Windows] 批处理文件系统服务控制
  3. Qt之重启应用程序
  4. AspNetPager 自定义html
  5. hdu 找新朋友
  6. AS3聊天单行输入框图文混排完美实现
  7. 【Cloud Foundry】Could Foundry学习(三)——Router
  8. jq选择器对象筛选
  9. pyspider 初次使用
  10. centos 日志文件
  11. 【Eclipse】_Eclipse自动补全增强方法 &amp; 常用快捷键
  12. CentOS 7安装WordPress
  13. day5 模拟购物车程序
  14. HTML-CSS-JS-JQ常用知识点总结
  15. python Scrapy 常见问题记录
  16. 改变html中的内容
  17. iOS.Book.Mac OS X and iOS Internals: To the Apple’s Core
  18. django时区设置(timezone)
  19. markdown转换为html
  20. Dictionary GetOrAdd

热门文章

  1. android 往sd卡中写入文件
  2. SaltStack远程执行Windows job程序(黑窗口)填坑经过
  3. springboot中pageHelper插件 list设置不进去 为null
  4. Jmeter性能测试 入门【转】
  5. Python---求100以内的质数
  6. csps模拟测试7576一句话题解
  7. 记录一次dubbo不能正常抛出特定异常
  8. JS-jquery 获取当前点击的对象
  9. css 阴影设置box-shadow
  10. Java基础(业务问题)