Going Home
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21010   Accepted: 10614

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

Source

比较好理解,给定一个N*M的地图,地图上有若干个man和house,且man与house的数量一致。man每移动一格需花费$1(即单位费用=单位距离),一间house只能入住一个man。现在要求所有的man都入住house,求最小费用。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#include <set>
using namespace std;
#define MM(a,b) memset(a,b,sizeof(a))
typedef long long ll;
typedef unsigned long long ULL;
const int mod = 1000000007;
const double eps = 1e-10;
const int inf = 0x3f3f3f3f;
const int big=50000;
int max(int a,int b) {return a>b?a:b;};
int min(int a,int b) {return a<b?a:b;};
const int N = 70;
const int M=10000+100;
struct edge{
int to,cap,cost,rev;
}; vector<edge> G[1005];
int dist[1005],inq[1005],prev[1005],prel[1005];
struct Point{
int x,y;
}; int n,m,x,y,c,cnth,cntm;
Point house[105],men[105]; void add_edge(int u,int v,int cap,int cost)
{
G[u].push_back(edge{v,cap,cost,G[v].size()});
G[v].push_back(edge{u,0,-cost,G[u].size()-1});
} int mincost(int s,int t,int f)
{
int ans=0;
while(f>0)
{
memset(dist,inf,sizeof(dist));
memset(inq,0,sizeof(inq));
dist[s]=0;
queue<int> q;
q.push(s);
inq[s]=1;
MM(prev,-1);
while(!q.empty())
{
int u=q.front();
q.pop();inq[u]=0;
for(int j=0;j<G[u].size();j++)
{
edge &e=G[u][j];
if(e.cap>0&&dist[e.to]>dist[u]+e.cost)
{
dist[e.to]=dist[u]+e.cost;
prev[e.to]=u;
prel[e.to]=j;
if(!inq[e.to])
{
q.push(e.to);
inq[e.to]=1;
}
}
}
}
for(int i=t;i>s;)
{
int f=prev[i];
if(f==-1) return -1;
int j=prel[i];
G[f][j].cap-=1;
G[i][G[f][j].rev].cap+=1;
ans+=G[f][j].cost;
i=prev[i];
}
f-=1;
}
return ans;
} void build()
{
for(int i=0;i<=cnth+cntm+1;i++) G[i].clear();
for(int i=1;i<=cntm;i++)
add_edge(0,i,1,0);
for(int i=1;i<=cnth;i++)
add_edge(cntm+i,cntm+cnth+1,1,0);
for(int i=1;i<=cntm;i++)
for(int j=1;j<=cnth;j++)
{
int dis=abs(house[j].x-men[i].x)+abs(house[j].y-men[i].y);
add_edge(i,j+cntm,1,dis);
}
} char s[105][105];
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m)&&(n||m))
{
cnth=cntm=0;
for(int i=1;i<=n;i++)
{
scanf("%s",s[i]);
for(int j=0;j<m;j++)
if(s[i][j]=='H')
house[++cnth]=(Point){i,j+1};
else if(s[i][j]=='m')
men[++cntm]=(Point){i,j+1};
}
build();
printf("%d\n",mincost(0,cnth+cntm+1,cnth));
}
return 0;
}

  分析:建图有一点点技术含量,人放左边,门放右边,加一个源点与汇点,然后跑一跑大小为人数(门数)的最小费用流就好,

最新文章

  1. JQuery_DOM 节点操作之复制、替换和 删除节点
  2. Zepto API 学习
  3. 【GoLang】GoLang 错误处理 -- 官方推荐方式 示例
  4. Linux Shell常用快捷键
  5. BI之SSAS完整实战教程3 -- 创建第一个多维数据集
  6. 转 How to install XenServer Tools – Linux(forward)
  7. 1-3-1 关于API
  8. Javascript模块规范(CommonJS规范&amp;&amp;AMD规范)
  9. Nodejs常见安装
  10. RedisService
  11. 捉Bug:易车注册页布局小臭虫 附demo
  12. JavaScript实现360度全景图片展示效果
  13. 分布式一致性算法:Raft 算法(论文翻译)
  14. 201521123089 《Java程序设计》第1周学习总结
  15. string函数详解(配案例)
  16. JS高德地图应用 ---- 鼠标点击加入标记 &amp; POI搜索
  17. Jenkins构建后发送邮件
  18. 安装VMwareTool
  19. [C语言]在命令行编译执行程序
  20. Python __init__ 特殊方法

热门文章

  1. HDU-5238 Calculator
  2. postman 获取登录成功后存在在header中cookies,并在下一个接口中使用。
  3. python-day29(正式学习)
  4. Web前端开发HTML基础
  5. springboot mongodb jpa常用方法整理
  6. Object.keys()返回对象自身可枚举属性组成的数组
  7. 解决跨域问题,前端 live-server --port=1802 后端启动 localhost:1801,以及解决 vue 的 axios 请求整合
  8. 21、Nginx 常见问题
  9. python爬虫练习之批量下载zabbix文档
  10. PHP强制修改返回的状态码