解题思路:给出两个数列an,bn,求an和bn中相同元素的个数
因为注意到n的取值是0到1000000,所以可以用二分查找来做,因为题目中给出的an,bn,已经是单调递增的,所以不用排序了,对于输入的每一个b[i],查找它在an数列中是否存在。存在返回值为1,不存在返回值为0

CD

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 627    Accepted Submission(s): 280

Problem Description
Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?
Neither Jack nor Jill owns more than one copy of each CD.
 
Input
The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.
 
Output
For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.
 
Sample Input
3 3
1
2
3
1
2
4
0 0
 
Sample Output
2
 
#include<stdio.h>
#include<string.h>
int a[1000005],b[1000005];
int bsearch(int a[],int n,int t)
{
int x,y,m;
x=1;
y=n;
while(x<=y)
{
m=(x+y)/2;
if(a[m]==t)
return 1;
else
{
if(a[m]>t)
y=m-1;
else
x=m+1;
} }
return 0;
}
int main()
{
int n,m,i,t,num;
while(scanf("%d %d",&n,&m)!=EOF&&(n||m))
{
num=0;
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;i<=m;i++)
{
scanf("%d",&b[i]);
num+=bsearch(a,n,b[i]);
}
printf("%d\n",num);
}
}

  

最新文章

  1. C指针-数组和指针的归一
  2. 启动Tomcat时报 Expected stackmap frame at this location.(JDK1.7编译)
  3. 两个实用的方法从Base64字符串生成RSAPublicKey及RSAPrivatekey
  4. zsh
  5. 堡垒机环境-jumpserver部署
  6. 屏蔽Win10升级通知方法
  7. wc命令--Linux统计文件行数
  8. Oracle数据库的下载和安装
  9. input元素有padding间距,所以使用box-sizing来保持宽度不超出父元素
  10. Window10安装TestLink,以及登录mysql数据库的错误处理
  11. AFNetworking3.0的基本使用方法
  12. [ios2]OS 6 SDK: 在应用内展示App Store【转】
  13. 如何在Eclipse下安装myeclipse插件
  14. Linux服务器硬盘状态查看
  15. [译]Python面试中8个必考问题
  16. sts中maven
  17. 玩转spring MVC(七)----拦截器
  18. spring5.0.2.RELEASE源码环境构建
  19. 微信小程序的MVVM思想
  20. PIL库图像处理

热门文章

  1. 超酷消息警告框插件(SweetAlert)
  2. Rx (Reactive Extensions)介绍
  3. Javase 简单练习
  4. ojdbc14:11.2.0.1.0出错
  5. 如何设置root登录(滴滴云)
  6. vue自己写了一个div菜单,点击按钮展开,点击其他地方关闭这个div菜单
  7. Linux的mysql搭建
  8. 【JavaScript框架封装】实现一个类似于JQuery的缓存框架的封装
  9. css+div 绘制多边形
  10. Oracle数据库性能优化基础