A - Robberies

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
 

Sample Output

2
4
6
 
2016.4.22,在做这道题时,发现依然问题多多。
1.概率是个小数,这次第一个思路是乘100然后用其作为消耗,这显然不对,首先double转int就会有误差,其次概率之间的关系不是简单的求和(显然读题不仔细)。题目中说的是,在小于被抓住的概率下拿到最多的钱,dp[0]被抓的概率为0不被抓的概率为1,由此应讨论不被抓的概率。dp[j]中存的是拿到j的价值而不被抓的概率。最后只需从后往前判断概率大小即可。
 
 
 
 题解:用不被抓到的概率来处理,状态转移方程相对简单。把可能抢到的钱数所对应的不被抓住的概率存入dp数组,再for(i=sum;i>=0;i++)如果能抢到的最大钱数所对应的不被抓概率大于(1-p)则输出i,然后跳出循环,该i值为最大钱数
 代码:
#include<stdio.h>
double max(double a,double b)
{
return a>b?a:b;
}
int main()
{
int t,n,M[110],i,j,sum;
double p,P[110],dp[10010]; //dp为背包最大容量
scanf("%d",&t);
while(t--)
{
sum=0;
scanf("%lf%d",&p,&n);
dp[0]=1; //当抢到的钱为零时,不被抓的概率为1
for(i=0; i<n; i++)
{
scanf("%d%lf",&M[i],&P[i]);
sum+=M[i];
}
for(i=1; i<=sum; i++) //需将除dp[0]以外的所有元素初始化为零,因为状态转移方程要比较大小再赋值,见图。之前错在此处。
dp[i]=0.0;
for(i=0; i<n; i++) //此循环为遍历银行
for(j=sum; j>=M[i]; j--) //此处不易理解。假设银行(1,0.02)(2,0.03)(3,0.05) 此循环大概功能:dp[6]=dp[3]*P[3],dp[3]=dp[1]*P[2].
dp[j]=max(dp[j],dp[j-M[i]]*(1-P[i])); //状态转移方程
for(i=sum; i>=0; i--)
if(dp[i]>=(1.0-p))
{
printf("%d\n",i);
break;
}
}
return 0;
}

  

最新文章

  1. android中实现view可以滑动的六种方法续篇(一)
  2. 判断返回数据是否为 null
  3. golang操作文件的四种方法
  4. 几种判断asp.net中session过期方法的比较
  5. 微信小程序正式上线 可置于聊天窗口顶部
  6. css考核点整理(十一)-响应式开发经验,响应式页面的三种核心技术是什么
  7. Windows与自定义USB HID设备通信说明.
  8. gis基本概念之&quot;投影变换&quot;-浅谈
  9. C++ primer学习方法
  10. 关于XMLEncoder和XMLDecoder
  11. gstreamer让playbin能够播放rtp over udp流数据
  12. 使用scrapy写好爬虫进行工作的时候,遇到错误及解决方法
  13. linux内核源码阅读之facebook硬盘加速flashcache之六
  14. 新书:《Liferay Portal 6.1最佳实践门户网站建设》
  15. tkinter第四章 输入框,校对
  16. BZOJ 4765: 普通计算姬 [分块 树状数组 DFS序]
  17. js中比较两个数组中是否含有相同的元素,可去重,可删除合并为新数组(转载)
  18. Oracle Metric sequence load elapsed time
  19. 201621123002《java程序设计》第九周学习总结
  20. NB-Iot的应用领域、覆盖范围,是什么

热门文章

  1. SSLStrip 终极版 —— location 瞒天过海
  2. 【SSO】--单点登录之过滤器(filter)
  3. dorker 安装
  4. hdu 1258 Sum It Up (dfs+路径记录)
  5. iOS学习笔记(4) — UITableView的 重用机制
  6. Canvas: trying to use a recycled bitmap android.graphics.Bitmap@XXX
  7. 危险的input 微博的过去
  8. 解决vs2010无法找到System.Data.OracleClient的引用问题
  9. [POI2011]LIZ-Lollipop
  10. gitlab https