uva 699

紫书P159

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?

We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value -1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single -1(which would otherwise represent an empty tree).

Output

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

Sample Input

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1

Sample Output

Case 1:
7 11 3 Case 2:
9 7 21 15 建树的过程可以很灵活,不要太过呆板
#include <iostream>
#include <cstring>
using namespace std;
const int maxn=;
int sum[maxn]; void Build(int u)
{
int v;
cin>>v;
if(v==-) return;
sum[u]+=v;
Build(u-);
Build(u+);
} bool Init()
{
memset(sum,,sizeof(sum));
int v;
cin>>v;
if(v==-) return false;
int pos=maxn/;
sum[pos]=v;
Build(pos-);
Build(pos+);
} int ca=;
void Output()
{
int p=;
while(sum[p]==) p++;
cout<<"Case "<<ca++<<":\n"<<sum[p];
while(sum[++p]!=) {cout<<" "<<sum[p];}
cout<<"\n\n";
} int main()
{
while(Init())
{
Output();
}
return ;
}

最新文章

  1. webuploader 谷歌浏览器跨域
  2. Python In Action:三、再来一个扩展例子,保证不难
  3. webAPI 数组参数
  4. c#.net循环将DataGridView中的数据赋值到Excel中,并设置样式
  5. c#获取枚举
  6. linux下安装小鹤双拼-鹤形
  7. 几道 SQL 语句面试题
  8. slice,substr,substring
  9. MFC 对话框中动态创建N级菜单以及响应事件
  10. ftk学习记(waitbox篇)
  11. [Erlang危机](5.1.0)VM检测概述
  12. 关于FPU
  13. PHP的AES加密类
  14. 【Android Studio安装部署系列】十一、Android studio获取数字签名信息
  15. Unity3d项目入门之打Apk包
  16. Trap 冷启动与热启动告警
  17. springcloud如何实现服务的平滑发布
  18. GLSL版本的区别和对比
  19. .NET面试题系列(十二)Dictionary原理
  20. 【搜索】 Prime Path

热门文章

  1. Java学习笔记——反射
  2. 0629-TP整理四(create(),success(),error(),U())
  3. codechef : TREDEG , Trees and Degrees
  4. SQL 理论知识总结
  5. Hdu 3487 play the chain
  6. 使用Oracle SQL Developer迁移MySQL至Oracle数据库
  7. 全面学习ORACLE Scheduler特性(11)使用Job Classes
  8. MVC学习-发送请求
  9. go 语言开发环境的安装与配置
  10. 继承static的注意点